Savian.CoreConverters.Converters Namespace

SEGYlib -Geological Survey of Canada, Natural Resource Canada
Savian.CoreConverters.Converters Namespace

[Missing <summary> documentation for "N:Savian.CoreConverters.Converters"]

Classes
 | Class | Description
Public class | Common |
Public class | Converter |
Public class | GlobalMembersLibNumber |
Structures
 | Structure | Description
Public structure | Ieee4Bytes |
Public structure | Ieee8Bytes |
Enumerations
 | Enumeration | Description
Public enumeration | Endian |
Public enumeration | FloatType |
Public enumeration | MethodNumber |
Public enumeration | Platform |
Send comments on this topic to bob.courtney@canada.ca


Common Class

Common Class

[Missing <summary> documentation for "T:Savian.CoreConverters.Converters.Common"]

Inheritance Hierarchy
SystemObject
Savian.CoreConverters.ConvertersCommon

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Common
Public NotInheritable Class Common
public ref class Common abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Common =  class end

The Common type exposes the following members.

Properties
Name | Description
Endian |
Top
See Also

Reference

Savian.CoreConverters.Converters Namespace


Common Properties

Common Properties

The Common type exposes the following members.

Properties
Name | Description
Endian |
Top
See Also

Reference

Common Class
Savian.CoreConverters.Converters Namespace


Common.Endian Property

CommonEndian Property

[Missing <summary> documentation for "P:Savian.CoreConverters.Converters.Common.Endian"]

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Endian Endian { get; set; }
Public Shared Property Endian As Endian
    Get
    Set
public:
static property Endian Endian {
    Endian get ();
    void set (Endian value);
}
static member Endian : Endian with get, set

Property Value

Type: Endian
See Also

Reference

Common Class
Savian.CoreConverters.Converters Namespace


Converter Class

Converter Class

[Missing <summary> documentation for "T:Savian.CoreConverters.Converters.Converter"]

Inheritance Hierarchy
SystemObject
Savian.CoreConverters.ConvertersConverter

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Converter
Public Class Converter
public ref class Converter
type Converter =  class end

The Converter type exposes the following members.

Constructors
 | Name | Description
Public method | Converter | Initializes a new instance of the Converter class
Top
Methods
 | Name | Description
Public method | ConvertBytesToDouble | Converts a series of bytes to a double after conversion. Only 8 bytes are allowed.
Public method | ConvertBytesToSingle | Converts a series of bytes to a single after conversion. Only 4 bytes are allowed.
Public method | ConvertDoubleToBytes | Converts a double to a series of bytes.
Public method | ConvertSingleToBytes | Converts a single to a series of bytes.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Savian.CoreConverters.Converters Namespace


Converter Constructor

Converter Constructor
Initializes a new instance of the Converter class

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Converter()
Public Sub New
public:
Converter()
new : unit -> Converter
See Also

Reference

Converter Class
Savian.CoreConverters.Converters Namespace


Converter Methods

Converter Methods

The Converter type exposes the following members.

Methods
 | Name | Description
Public method | ConvertBytesToDouble | Converts a series of bytes to a double after conversion. Only 8 bytes are allowed.
Public method | ConvertBytesToSingle | Converts a series of bytes to a single after conversion. Only 4 bytes are allowed.
Public method | ConvertDoubleToBytes | Converts a double to a series of bytes.
Public method | ConvertSingleToBytes | Converts a single to a series of bytes.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Process |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Converter Class
Savian.CoreConverters.Converters Namespace


Converter.ConvertBytesToDouble Method

ConverterConvertBytesToDouble Method
Converts a series of bytes to a double after conversion. Only 8 bytes are allowed.

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ConvertBytesToDouble(
    Platform platform,
    byte[] bytes
)
Public Function ConvertBytesToDouble (
    platform As Platform,
    bytes As Byte()
) As Double
public:
double ConvertBytesToDouble(
    Platform platform,
    array<unsigned char>^ bytes
)
member ConvertBytesToDouble :
        platform : Platform *
        bytes : byte[] -> float

Parameters

platform
Type: Savian.CoreConverters.ConvertersPlatform
The platform where the bytes originated
bytes
Type: SystemByte
The series of byte sto evaulate

Return Value

Type: Double
A .NET double
See Also

Reference

Converter Class
Savian.CoreConverters.Converters Namespace


Converter.ConvertBytesToSingle Method

ConverterConvertBytesToSingle Method
Converts a series of bytes to a single after conversion. Only 4 bytes are allowed.

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ConvertBytesToSingle(
    Platform platform,
    byte[] bytes
)
Public Function ConvertBytesToSingle (
    platform As Platform,
    bytes As Byte()
) As Double
public:
double ConvertBytesToSingle(
    Platform platform,
    array<unsigned char>^ bytes
)
member ConvertBytesToSingle :
        platform : Platform *
        bytes : byte[] -> float

Parameters

platform
Type: Savian.CoreConverters.ConvertersPlatform
The platform where the bytes originated
bytes
Type: SystemByte
The series of byte sto evaulate

Return Value

Type: Double
A .NET double
See Also

Reference

Converter Class
Savian.CoreConverters.Converters Namespace


Converter.ConvertDoubleToBytes Method

ConverterConvertDoubleToBytes Method
Converts a double to a series of bytes.

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] ConvertDoubleToBytes(
    Platform platform,
    double value
)
Public Function ConvertDoubleToBytes (
    platform As Platform,
    value As Double
) As Byte()
public:
array<unsigned char>^ ConvertDoubleToBytes(
    Platform platform,
    double value
)
member ConvertDoubleToBytes :
        platform : Platform *
        value : float -> byte[]

Parameters

platform
Type: Savian.CoreConverters.ConvertersPlatform
The platform where the bytes are destined. A VAX does not use a double so the return value will always be 0 for a VAX.
value
Type: SystemDouble
The double value to convert to bytes

Return Value

Type: Byte
A byte array
See Also

Reference

Converter Class
Savian.CoreConverters.Converters Namespace


Converter.ConvertSingleToBytes Method

ConverterConvertSingleToBytes Method
Converts a single to a series of bytes.

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] ConvertSingleToBytes(
    Platform platform,
    float value
)
Public Function ConvertSingleToBytes (
    platform As Platform,
    value As Single
) As Byte()
public:
array<unsigned char>^ ConvertSingleToBytes(
    Platform platform,
    float value
)
member ConvertSingleToBytes :
        platform : Platform *
        value : float32 -> byte[]

Parameters

platform
Type: Savian.CoreConverters.ConvertersPlatform
The platform where the bytes are destined.
value
Type: SystemSingle
The single value to convert to bytes

Return Value

Type: Byte
A byte array
See Also

Reference

Converter Class
Savian.CoreConverters.Converters Namespace


Converter.Process Method

ConverterProcess Method

[Missing <summary> documentation for "M:Savian.CoreConverters.Converters.Converter.Process"]

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Process()
Public Sub Process
public:
void Process()
member Process : unit -> unit
See Also

Reference

Converter Class
Savian.CoreConverters.Converters Namespace


Endian Enumeration

Endian Enumeration

[Missing <summary> documentation for "T:Savian.CoreConverters.Converters.Endian"]

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum Endian
Public Enumeration Endian
public enum class Endian
type Endian
Members
Member name | Value | Description
BigEndian | 1 |
LittleEndian | 2 |
See Also

Reference

Savian.CoreConverters.Converters Namespace


FloatType Enumeration

FloatType Enumeration

[Missing <summary> documentation for "T:Savian.CoreConverters.Converters.FloatType"]

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FloatType
Public Enumeration FloatType
public enum class FloatType
type FloatType
Members
Member name | Value | Description
IeeeSingleFloat | 0 |
IeeeDoubleFloat | 1 |
IbmSingleFloat | 2 |
IbmDoubleFloat | 3 |
VaxSingleFloat | 4 |
See Also

Reference

Savian.CoreConverters.Converters Namespace


GlobalMembersLibNumber Class

GlobalMembersLibNumber Class

[Missing <summary> documentation for "T:Savian.CoreConverters.Converters.GlobalMembersLibNumber"]

Inheritance Hierarchy
SystemObject
Savian.CoreConverters.ConvertersGlobalMembersLibNumber

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class GlobalMembersLibNumber
Public NotInheritable Class GlobalMembersLibNumber
public ref class GlobalMembersLibNumber abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GlobalMembersLibNumber =  class end
See Also

Reference

Savian.CoreConverters.Converters Namespace


Ieee4Bytes Structure

Ieee4Bytes Structure

[Missing <summary> documentation for "T:Savian.CoreConverters.Converters.Ieee4Bytes"]

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct Ieee4Bytes
Public Structure Ieee4Bytes
public value class Ieee4Bytes
[<SealedAttribute>]
type Ieee4Bytes =  struct end

The Ieee4Bytes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | b |
Public field | f |
Public field | l |
Top
See Also

Reference

Savian.CoreConverters.Converters Namespace


Ieee4Bytes Methods

Ieee4Bytes Methods

The Ieee4Bytes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Ieee4Bytes Structure
Savian.CoreConverters.Converters Namespace


Ieee4Bytes Fields

Ieee4Bytes Fields

The Ieee4Bytes type exposes the following members.

Fields
 | Name | Description
Public field | b |
Public field | f |
Public field | l |
Top
See Also

Reference

Ieee4Bytes Structure
Savian.CoreConverters.Converters Namespace


Ieee4Bytes.b Field

Ieee4Bytesb Field

[Missing <summary> documentation for "F:Savian.CoreConverters.Converters.Ieee4Bytes.b"]

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] b
Public b As Byte()
public:
array<unsigned char>^ b
val mutable b: byte[]

Field Value

Type: Byte
See Also

Reference

Ieee4Bytes Structure
Savian.CoreConverters.Converters Namespace


Ieee4Bytes.f Field

Ieee4Bytesf Field

[Missing <summary> documentation for "F:Savian.CoreConverters.Converters.Ieee4Bytes.f"]

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public float f
Public f As Single
public:
float f
val mutable f: float32

Field Value

Type: Single
See Also

Reference

Ieee4Bytes Structure
Savian.CoreConverters.Converters Namespace


Ieee4Bytes.l Field

Ieee4Bytesl Field

[Missing <summary> documentation for "F:Savian.CoreConverters.Converters.Ieee4Bytes.l"]

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint l
Public l As UInteger
public:
unsigned int l
val mutable l: uint32

Field Value

Type: UInt32
See Also

Reference

Ieee4Bytes Structure
Savian.CoreConverters.Converters Namespace


Ieee8Bytes Structure

Ieee8Bytes Structure

[Missing <summary> documentation for "T:Savian.CoreConverters.Converters.Ieee8Bytes"]

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct Ieee8Bytes
Public Structure Ieee8Bytes
public value class Ieee8Bytes
[<SealedAttribute>]
type Ieee8Bytes =  struct end

The Ieee8Bytes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | b |
Public field | f |
Public field | l |
Top
See Also

Reference

Savian.CoreConverters.Converters Namespace


Ieee8Bytes Methods

Ieee8Bytes Methods

The Ieee8Bytes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Ieee8Bytes Structure
Savian.CoreConverters.Converters Namespace


Ieee8Bytes Fields

Ieee8Bytes Fields

The Ieee8Bytes type exposes the following members.

Fields
 | Name | Description
Public field | b |
Public field | f |
Public field | l |
Top
See Also

Reference

Ieee8Bytes Structure
Savian.CoreConverters.Converters Namespace


Ieee8Bytes.b Field

Ieee8Bytesb Field

[Missing <summary> documentation for "F:Savian.CoreConverters.Converters.Ieee8Bytes.b"]

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] b
Public b As Byte()
public:
array<unsigned char>^ b
val mutable b: byte[]

Field Value

Type: Byte
See Also

Reference

Ieee8Bytes Structure
Savian.CoreConverters.Converters Namespace


Ieee8Bytes.f Field

Ieee8Bytesf Field

[Missing <summary> documentation for "F:Savian.CoreConverters.Converters.Ieee8Bytes.f"]

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double f
Public f As Double
public:
double f
val mutable f: float

Field Value

Type: Double
See Also

Reference

Ieee8Bytes Structure
Savian.CoreConverters.Converters Namespace


Ieee8Bytes.l Field

Ieee8Bytesl Field

[Missing <summary> documentation for "F:Savian.CoreConverters.Converters.Ieee8Bytes.l"]

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ulong l
Public l As ULong
public:
unsigned long long l
val mutable l: uint64

Field Value

Type: UInt64
See Also

Reference

Ieee8Bytes Structure
Savian.CoreConverters.Converters Namespace


MethodNumber Enumeration

MethodNumber Enumeration

[Missing <summary> documentation for "T:Savian.CoreConverters.Converters.MethodNumber"]

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MethodNumber
Public Enumeration MethodNumber
public enum class MethodNumber
type MethodNumber
Members
Member name | Value | Description
ByMultiple | 0 |
ByLog | 1 |
See Also

Reference

Savian.CoreConverters.Converters Namespace


Platform Enumeration

Platform Enumeration

[Missing <summary> documentation for "T:Savian.CoreConverters.Converters.Platform"]

Namespace: Savian.CoreConverters.Converters
Assembly: Converters (in Converters.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum Platform
Public Enumeration Platform
public enum class Platform
type Platform
Members
Member name | Value | Description
IbmFloat | 0 |
IeeeFloat | 1 |
VaxFloat | 2 |
See Also

Reference

Savian.CoreConverters.Converters Namespace


SEGYlib Namespace

SEGYlib Namespace

[Missing <summary> documentation for "N:SEGYlib"]

Classes
 | Class | Description
Public class | SEGYFile | Top level class for reading and writing SEGY files
Public class | SEGYFileHeader | Class for storing and retrieving data stored in the SEGY file Header
Public class | SEGYTrace | SEGYTrace is used to access and set SEGY rev 1 trace data
Public class | SEGYTraceData | SEGYTraceData allows access to the contents of the binary trace data
Public class | SEGYTraceHeader | SEGYTraceHeader is used to access and change contents of the binary trace header data block
Public class | SEGYUtilities | SEGYUtilities for use in reading and writing SEGY files


SEGYFile Class

SEGYFile Class
Top level class for reading and writing SEGY files
Inheritance Hierarchy
SystemObject
SEGYlibSEGYFile

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SEGYFile
<SerializableAttribute>
Public Class SEGYFile
[SerializableAttribute]
public ref class SEGYFile
[<SerializableAttribute>]
type SEGYFile =  class end

The SEGYFile type exposes the following members.

Constructors
 | Name | Description
Public method | SEGYFile | Initializes a new instance of the SEGYFile class
Top
Properties
 | Name | Description
Public property | currentTrace | last trace read from file
Public property | FileHeader | access to File Header Class
Public property | NumberOfTracesInBuffer | number of traces in Trace list
Public property | Traces | List of traces including data and trace headers
Top
Methods
 | Name | Description
Public method | AddTrace | add a trace to the end of the Traces list
Public method | Close | close I/O channels
Public method | CopyAllTraces | make a deep copy of the Traces List
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GoToStartOfTrace | position the stream reader/writer at the start of the n'th trace
Public method | isSEGY | test to see if input file is a SEGY file
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFilePointerToStartOfTraces | move file pointer to the end of the file header blocks
Public method | Open | open or create a SEGY file returns 0 if unsuccessful; 1 if non zero length file ; 2 is empty file
Public method | ReadAllTraceHeaders | read all trace headers but don't load trace data
Public method | ReadAllTraces | read all trace headers including trace data
Public method | ReadFileHeader | read the file headers
Public method | ReadNextTrace | read the next trace in the file
Public method | ReadNTraces | read the next n traces in the file
 | ReadXML | read an SEGY file in XML format
 | ReadXMLFileHeader | read an SEGY file header in XML format
 | ReadXMLTrace | read an SEGY trace in XML format
Public method | ReindexTracePositions | re-read the file and reindex the trace locations
Public method | RemoveAllTraces | delete all trace storage
Public method | RemoveTrace | remove trace i from the Traces list
Public method | SkipNTracesOnRead | skip ntraces
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(String) | write the entire file to disk
Public method | Write(SEGYFileHeader) | write the file header to disk
Public method | Write(SEGYTrace) | write a trace to disk
Public method | Write(ListSEGYTrace) | write the list Traces to disk
Public method | WriteXML(String) | write the file to XML
Public method | WriteXML(String, SEGYFileHeader) | write the file header to XML
Public method | WriteXML(String, SEGYTrace) | write the trace to XML
Top
Fields
 | Name | Description
Public field | isBigEndian | true for big endian file; false little endian
Top
See Also

Reference

SEGYlib Namespace


SEGYFile Constructor

SEGYFile Constructor
Initializes a new instance of the SEGYFile class

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SEGYFile()
Public Sub New
public:
SEGYFile()
new : unit -> SEGYFile
See Also

Reference

SEGYFile Class


SEGYFile Properties

SEGYFile Properties

The SEGYFile type exposes the following members.

Properties
 | Name | Description
Public property | currentTrace | last trace read from file
Public property | FileHeader | access to File Header Class
Public property | NumberOfTracesInBuffer | number of traces in Trace list
Public property | Traces | List of traces including data and trace headers
Top
See Also

Reference

SEGYFile Class


SEGYFile.currentTrace Property

SEGYFilecurrentTrace Property
last trace read from file

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SEGYTrace currentTrace { get; set; }
Public Property currentTrace As SEGYTrace
    Get
    Set
public:
property SEGYTrace^ currentTrace {
    SEGYTrace^ get ();
    void set (SEGYTrace^ value);
}
member currentTrace : SEGYTrace with get, set

Property Value

Type: SEGYTrace
See Also

Reference

SEGYFile Class


SEGYFile.FileHeader Property

SEGYFileFileHeader Property
access to File Header Class

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SEGYFileHeader FileHeader { get; set; }
Public Property FileHeader As SEGYFileHeader
    Get
    Set
public:
property SEGYFileHeader^ FileHeader {
    SEGYFileHeader^ get ();
    void set (SEGYFileHeader^ value);
}
member FileHeader : SEGYFileHeader with get, set

Property Value

Type: SEGYFileHeader
See Also

Reference

SEGYFile Class


SEGYFile.NumberOfTracesInBuffer Property

SEGYFileNumberOfTracesInBuffer Property
number of traces in Trace list

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfTracesInBuffer { get; set; }
Public Property NumberOfTracesInBuffer As Integer
    Get
    Set
public:
property int NumberOfTracesInBuffer {
    int get ();
    void set (int value);
}
member NumberOfTracesInBuffer : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYFile Class


SEGYFile.Traces Property

SEGYFileTraces Property
List of traces including data and trace headers

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<SEGYTrace> Traces { get; set; }
Public Property Traces As List(Of SEGYTrace)
    Get
    Set
public:
property List<SEGYTrace^>^ Traces {
    List<SEGYTrace^>^ get ();
    void set (List<SEGYTrace^>^ value);
}
member Traces : List<SEGYTrace> with get, set

Property Value

Type: List SEGYTrace
See Also

Reference

SEGYFile Class


SEGYFile Methods

SEGYFile Methods

The SEGYFile type exposes the following members.

Methods
 | Name | Description
Public method | AddTrace | add a trace to the end of the Traces list
Public method | Close | close I/O channels
Public method | CopyAllTraces | make a deep copy of the Traces List
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GoToStartOfTrace | position the stream reader/writer at the start of the n'th trace
Public method | isSEGY | test to see if input file is a SEGY file
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFilePointerToStartOfTraces | move file pointer to the end of the file header blocks
Public method | Open | open or create a SEGY file returns 0 if unsuccessful; 1 if non zero length file ; 2 is empty file
Public method | ReadAllTraceHeaders | read all trace headers but don't load trace data
Public method | ReadAllTraces | read all trace headers including trace data
Public method | ReadFileHeader | read the file headers
Public method | ReadNextTrace | read the next trace in the file
Public method | ReadNTraces | read the next n traces in the file
 | ReadXML | read an SEGY file in XML format
 | ReadXMLFileHeader | read an SEGY file header in XML format
 | ReadXMLTrace | read an SEGY trace in XML format
Public method | ReindexTracePositions | re-read the file and reindex the trace locations
Public method | RemoveAllTraces | delete all trace storage
Public method | RemoveTrace | remove trace i from the Traces list
Public method | SkipNTracesOnRead | skip ntraces
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(String) | write the entire file to disk
Public method | Write(SEGYFileHeader) | write the file header to disk
Public method | Write(SEGYTrace) | write a trace to disk
Public method | Write(ListSEGYTrace) | write the list Traces to disk
Public method | WriteXML(String) | write the file to XML
Public method | WriteXML(String, SEGYFileHeader) | write the file header to XML
Public method | WriteXML(String, SEGYTrace) | write the trace to XML
Top
See Also

Reference

SEGYFile Class


SEGYFile.AddTrace Method

SEGYFileAddTrace Method
add a trace to the end of the Traces list

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddTrace(
    SEGYTrace trace
)
Public Sub AddTrace (
    trace As SEGYTrace
)
public:
void AddTrace(
    SEGYTrace^ trace
)
member AddTrace :
        trace : SEGYTrace -> unit

Parameters

trace
Type: SEGYlibSEGYTrace
add a trace
See Also

Reference

SEGYFile Class


SEGYFile.Close Method

SEGYFileClose Method
close I/O channels

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
void Close()
member Close : unit -> unit
See Also

Reference

SEGYFile Class


SEGYFile.CopyAllTraces Method

SEGYFileCopyAllTraces Method
make a deep copy of the Traces List

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<SEGYTrace> CopyAllTraces()
Public Function CopyAllTraces As List(Of SEGYTrace)
public:
List<SEGYTrace^>^ CopyAllTraces()
member CopyAllTraces : unit -> List<SEGYTrace>

Return Value

Type: List SEGYTrace
pointer to new List of SEGYTraces
See Also

Reference

SEGYFile Class


SEGYFile.GoToStartOfTrace Method

SEGYFileGoToStartOfTrace Method
position the stream reader/writer at the start of the n'th trace

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool GoToStartOfTrace(
    int n
)
Public Function GoToStartOfTrace (
    n As Integer
) As Boolean
public:
bool GoToStartOfTrace(
    int n
)
member GoToStartOfTrace :
        n : int -> bool

Parameters

n
Type: SystemInt32
trace id

Return Value

Type: Boolean
true is successful
See Also

Reference

SEGYFile Class


SEGYFile.isSEGY Method

SEGYFileisSEGY Method
test to see if input file is a SEGY file

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool isSEGY()
Public Function isSEGY As Boolean
public:
bool isSEGY()
member isSEGY : unit -> bool

Return Value

Type: Boolean
true is the input file has acceptable FileHeader.dataSampleFormatCode and FileHeader.dataSampleFormatCode
See Also

Reference

SEGYFile Class


SEGYFile.MoveFilePointerToStartOfTraces Method

SEGYFileMoveFilePointerToStartOfTraces Method
move file pointer to the end of the file header blocks

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MoveFilePointerToStartOfTraces()
Public Sub MoveFilePointerToStartOfTraces
public:
void MoveFilePointerToStartOfTraces()
member MoveFilePointerToStartOfTraces : unit -> unit
See Also

Reference

SEGYFile Class


SEGYFile.Open Method

SEGYFileOpen Method
open or create a SEGY file returns 0 if unsuccessful; 1 if non zero length file ; 2 is empty file

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Open(
    string inputFilename
)
Public Function Open (
    inputFilename As String
) As Integer
public:
int Open(
    String^ inputFilename
)
member Open :
        inputFilename : string -> int

Parameters

inputFilename
Type: SystemString
SEGY file name

Return Value

Type: Int32
0 - not successful; 1 - opened an existing file; 2 - created a new file
See Also

Reference

SEGYFile Class


SEGYFile.ReadAllTraceHeaders Method

SEGYFileReadAllTraceHeaders Method
read all trace headers but don't load trace data

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ReadAllTraceHeaders()
Public Sub ReadAllTraceHeaders
public:
void ReadAllTraceHeaders()
member ReadAllTraceHeaders : unit -> unit
See Also

Reference

SEGYFile Class


SEGYFile.ReadAllTraces Method

SEGYFileReadAllTraces Method
read all trace headers including trace data

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ReadAllTraces()
Public Sub ReadAllTraces
public:
void ReadAllTraces()
member ReadAllTraces : unit -> unit
See Also

Reference

SEGYFile Class


SEGYFile.ReadFileHeader Method

SEGYFileReadFileHeader Method
read the file headers

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReadFileHeader()
Public Function ReadFileHeader As Boolean
public:
bool ReadFileHeader()
member ReadFileHeader : unit -> bool

Return Value

Type: Boolean
true is successful
See Also

Reference

SEGYFile Class


SEGYFile.ReadNextTrace Method

SEGYFileReadNextTrace Method
read the next trace in the file

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReadNextTrace()
Public Function ReadNextTrace As Boolean
public:
bool ReadNextTrace()
member ReadNextTrace : unit -> bool

Return Value

Type: Boolean
true is successful
See Also

Reference

SEGYFile Class


SEGYFile.ReadNTraces Method

SEGYFileReadNTraces Method
read the next n traces in the file

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReadNTraces(
    int n
)
Public Function ReadNTraces (
    n As Integer
) As Boolean
public:
bool ReadNTraces(
    int n
)
member ReadNTraces :
        n : int -> bool

Parameters

n
Type: SystemInt32
number of traces to read

Return Value

Type: Boolean
true is successful
See Also

Reference

SEGYFile Class


SEGYFile.ReadXML Method

SEGYFileReadXML Method
read an SEGY file in XML format

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SEGYFile ReadXML(
    string inputXMLFileName
)
Public Shared Function ReadXML (
    inputXMLFileName As String
) As SEGYFile
public:
static SEGYFile^ ReadXML(
    String^ inputXMLFileName
)
static member ReadXML :
        inputXMLFileName : string -> SEGYFile

Parameters

inputXMLFileName
Type: SystemString
input SEGYFile XML file name

Return Value

Type: SEGYFile
pointer to SEGYFile
See Also

Reference

SEGYFile Class


SEGYFile.ReadXMLFileHeader Method

SEGYFileReadXMLFileHeader Method
read an SEGY file header in XML format

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SEGYFileHeader ReadXMLFileHeader(
    string inputXMLFileName
)
Public Shared Function ReadXMLFileHeader (
    inputXMLFileName As String
) As SEGYFileHeader
public:
static SEGYFileHeader^ ReadXMLFileHeader(
    String^ inputXMLFileName
)
static member ReadXMLFileHeader :
        inputXMLFileName : string -> SEGYFileHeader

Parameters

inputXMLFileName
Type: SystemString
input SEGYFileHeader XML file name

Return Value

Type: SEGYFileHeader
point to SEGYFileHeader
See Also

Reference

SEGYFile Class


SEGYFile.ReadXMLTrace Method

SEGYFileReadXMLTrace Method
read an SEGY trace in XML format

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SEGYTrace ReadXMLTrace(
    string inputXMLFileName
)
Public Shared Function ReadXMLTrace (
    inputXMLFileName As String
) As SEGYTrace
public:
static SEGYTrace^ ReadXMLTrace(
    String^ inputXMLFileName
)
static member ReadXMLTrace :
        inputXMLFileName : string -> SEGYTrace

Parameters

inputXMLFileName
Type: SystemString
input SEGYTrace XML file name

Return Value

Type: SEGYTrace
pointer to SEGYTrace
See Also

Reference

SEGYFile Class


SEGYFile.ReindexTracePositions Method

SEGYFileReindexTracePositions Method
re-read the file and reindex the trace locations

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ReindexTracePositions()
Public Sub ReindexTracePositions
public:
void ReindexTracePositions()
member ReindexTracePositions : unit -> unit
See Also

Reference

SEGYFile Class


SEGYFile.RemoveAllTraces Method

SEGYFileRemoveAllTraces Method
delete all trace storage

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveAllTraces()
Public Function RemoveAllTraces As Boolean
public:
bool RemoveAllTraces()
member RemoveAllTraces : unit -> bool

Return Value

Type: Boolean
true is successful
See Also

Reference

SEGYFile Class


SEGYFile.RemoveTrace Method

SEGYFileRemoveTrace Method
remove trace i from the Traces list

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveTrace(
    int i
)
Public Function RemoveTrace (
    i As Integer
) As Boolean
public:
bool RemoveTrace(
    int i
)
member RemoveTrace :
        i : int -> bool

Parameters

i
Type: SystemInt32
trace number to remove from list

Return Value

Type: Boolean
true is successful
See Also

Reference

SEGYFile Class


SEGYFile.SkipNTracesOnRead Method

SEGYFileSkipNTracesOnRead Method
skip ntraces

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SkipNTracesOnRead(
    int skip
)
Public Function SkipNTracesOnRead (
    skip As Integer
) As Boolean
public:
bool SkipNTracesOnRead(
    int skip
)
member SkipNTracesOnRead :
        skip : int -> bool

Parameters

skip
Type: SystemInt32
number of traces to skip

Return Value

Type: Boolean
true is successful
See Also

Reference

SEGYFile Class


SEGYFile.Write Method

SEGYFileWrite Method
Overload List
 | Name | Description
Public method | Write(String) | write the entire file to disk
Public method | Write(SEGYFileHeader) | write the file header to disk
Public method | Write(SEGYTrace) | write a trace to disk
Public method | Write(ListSEGYTrace) | write the list Traces to disk
Top
See Also

Reference

SEGYFile Class


SEGYFile.Write Method (String)

SEGYFileWrite Method (String)
write the entire file to disk

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Write(
    string outputFileName
)
Public Function Write (
    outputFileName As String
) As Boolean
public:
bool Write(
    String^ outputFileName
)
member Write :
        outputFileName : string -> bool

Parameters

outputFileName
Type: SystemString
output file name

Return Value

Type: Boolean
true is successful
See Also

Reference

SEGYFile Class
Write Overload


SEGYFile.Write Method (SEGYFileHeader)

SEGYFileWrite Method (SEGYFileHeader)
write the file header to disk

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Write(
    SEGYFileHeader fileHeader
)
Public Function Write (
    fileHeader As SEGYFileHeader
) As Boolean
public:
bool Write(
    SEGYFileHeader^ fileHeader
)
member Write :
        fileHeader : SEGYFileHeader -> bool

Parameters

fileHeader
Type: SEGYlibSEGYFileHeader
input file header

Return Value

Type: Boolean
true is successful
See Also

Reference

SEGYFile Class
Write Overload


SEGYFile.Write Method (SEGYTrace)

SEGYFileWrite Method (SEGYTrace)
write a trace to disk

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Write(
    SEGYTrace trace
)
Public Function Write (
    trace As SEGYTrace
) As Boolean
public:
bool Write(
    SEGYTrace^ trace
)
member Write :
        trace : SEGYTrace -> bool

Parameters

trace
Type: SEGYlibSEGYTrace
input trace header

Return Value

Type: Boolean
true is successful
See Also

Reference

SEGYFile Class
Write Overload


SEGYFile.Write Method (List(SEGYTrace))

SEGYFileWrite Method (ListSEGYTrace)
write the list Traces to disk

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Write(
    List<SEGYTrace> traces
)
Public Function Write (
    traces As List(Of SEGYTrace)
) As Boolean
public:
bool Write(
    List<SEGYTrace^>^ traces
)
member Write :
        traces : List<SEGYTrace> -> bool

Parameters

traces
Type: System.Collections.GenericList SEGYTrace
List of SEGYTrace instances

Return Value

Type: Boolean
true is successful
See Also

Reference

SEGYFile Class
Write Overload


SEGYFile.WriteXML Method

SEGYFileWriteXML Method
Overload List
 | Name | Description
Public method | WriteXML(String) | write the file to XML
Public method | WriteXML(String, SEGYFileHeader) | write the file header to XML
Public method | WriteXML(String, SEGYTrace) | write the trace to XML
Top
See Also

Reference

SEGYFile Class


SEGYFile.WriteXML Method (String)

SEGYFileWriteXML Method (String)
write the file to XML

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool WriteXML(
    string outputXMLFileName
)
Public Function WriteXML (
    outputXMLFileName As String
) As Boolean
public:
bool WriteXML(
    String^ outputXMLFileName
)
member WriteXML :
        outputXMLFileName : string -> bool

Parameters

outputXMLFileName
Type: SystemString
output XML file name

Return Value

Type: Boolean
true is successful
See Also

Reference

SEGYFile Class
WriteXML Overload


SEGYFile.WriteXML Method (String, SEGYFileHeader)

SEGYFileWriteXML Method (String, SEGYFileHeader)
write the file header to XML

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool WriteXML(
    string outputXMLFileName,
    SEGYFileHeader fileheader
)
Public Function WriteXML (
    outputXMLFileName As String,
    fileheader As SEGYFileHeader
) As Boolean
public:
bool WriteXML(
    String^ outputXMLFileName,
    SEGYFileHeader^ fileheader
)
member WriteXML :
        outputXMLFileName : string *
        fileheader : SEGYFileHeader -> bool

Parameters

outputXMLFileName
Type: SystemString
output XML file name
fileheader
Type: SEGYlibSEGYFileHeader
input file header

Return Value

Type: Boolean
true is successful
See Also

Reference

SEGYFile Class
WriteXML Overload


SEGYFile.WriteXML Method (String, SEGYTrace)

SEGYFileWriteXML Method (String, SEGYTrace)
write the trace to XML

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool WriteXML(
    string outputXMLFileName,
    SEGYTrace trace
)
Public Function WriteXML (
    outputXMLFileName As String,
    trace As SEGYTrace
) As Boolean
public:
bool WriteXML(
    String^ outputXMLFileName,
    SEGYTrace^ trace
)
member WriteXML :
        outputXMLFileName : string *
        trace : SEGYTrace -> bool

Parameters

outputXMLFileName
Type: SystemString
output XML file name
trace
Type: SEGYlibSEGYTrace
input trace

Return Value

Type: Boolean
true is successful
See Also

Reference

SEGYFile Class
WriteXML Overload


SEGYFile Fields

SEGYFile Fields

The SEGYFile type exposes the following members.

Fields
 | Name | Description
Public field | isBigEndian | true for big endian file; false little endian
Top
See Also

Reference

SEGYFile Class


SEGYFile.isBigEndian Field

SEGYFileisBigEndian Field
true for big endian file; false little endian

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool isBigEndian
Public isBigEndian As Boolean
public:
bool isBigEndian
val mutable isBigEndian: bool

Field Value

Type: Boolean
See Also

Reference

SEGYFile Class


SEGYFileHeader Class

SEGYFileHeader Class
Class for storing and retrieving data stored in the SEGY file Header
Inheritance Hierarchy
SystemObject
SEGYlibSEGYFileHeader

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SEGYFileHeader
Public Class SEGYFileHeader
public ref class SEGYFileHeader
type SEGYFileHeader =  class end

The SEGYFileHeader type exposes the following members.

Constructors
 | Name | Description
Public method | SEGYFileHeader | constructor
Top
Properties
 | Name | Description
Public property | amplitudeRecoveryMethod | attribute defined though segy rev 1 standard
Public property | BinaryFileHeader | access to byte block of Binary File header
Public property | binaryGainRecovered | attribute defined though segy rev 1 standard
Public property | correlatedDataTraces | attribute defined though segy rev 1 standard
Public property | dataSampleFormatCode | attribute defined though segy rev 1 standard
Public property | ensembleFold | attribute defined though segy rev 1 standard
Public property | ExtendedTextHeader | lead 3200 byte tape header plus any other extended blocks
Public property | fixedLengthTraceFlag | attribute defined though segy rev 1 standard
Public property | impulseSignalPolarity | attribute defined though segy rev 1 standard
Public property | jobIdentificationNumberz | attribute defined though segy rev 1 standard
Public property | lengthOfFileHeader | byte length of file header including extended tape header and binary file header
Public property | lineNumber | attribute defined though segy rev 1 standard
Public property | measurementSystem | attribute defined though segy rev 1 standard
Public property | numberOfAuxilaryTracesPerEnsemble | attribute defined though segy rev 1 standard
Public property | numberOfDataTracesPerEnsemble | attribute defined though segy rev 1 standard
Public property | numberOfExtendedTextualFileHeaderRecordsFollowing | attribute defined though segy rev 1 standard
Public property | numberOfSamplesPerDataTrace | attribute defined though segy rev 1 standard
Public property | numberOfSamplesPerDataTraceForOriginalFieldRecording | attribute defined though segy rev 1 standard
Public property | reelNumber | attribute defined though segy rev 1 standard
Public property | sampleIntervalInMicroseconds | attribute defined though segy rev 1 standard
Public property | sampleIntervalInMicrosecondsInOriginalFieldRecording | attribute defined though segy rev 1 standard
Public property | segyFormatRevisionNumber | attribute defined though segy rev 1 standard
Public property | sweepCode | attribute defined though segy rev 1 standard
Public property | sweepFrequencyEnd | attribute defined though segy rev 1 standard
Public property | sweepFrequencyStart | attribute defined though segy rev 1 standard
Public property | sweepLength | attribute defined though segy rev 1 standard
Public property | sweepTraceTaperLengthAtEnd | attribute defined though segy rev 1 standard
Public property | sweepTraceTaperLengthAtStart | attribute defined though segy rev 1 standard
Public property | taperType | attribute defined though segy rev 1 standard
Public property | traceNumberSweepChannel | attribute defined though segy rev 1 standard
Public property | traceSortingCode | attribute defined though segy rev 1 standard
Public property | verticalSumCode | attribute defined though segy rev 1 standard
Public property | vibratoryPolarityCode | attribute defined though segy rev 1 standard
Top
Methods
 | Name | Description
Public method | Copy | make a deep copy of the Header
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFileHeaderText | get a string for the extended tape header
Public method | GetFileHeaderTextByLine | get the Text header by 80 character lines
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | isBigEndian | true for big endian and false for little endian
Public method | isFileHeaderASCII | is the file header encoded with ASCII or EBCDIC
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadFileHeader | read the file header from disk
Public method | SetFileHeader | set the Text Header by 80 character line
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteFileHeader | write the file header to disk
Top
Fields
 | Name | Description
Public field | isSEGYFileHeaderAscii | true if Text Header is ASCII; false if EBCDIC
Public field | positionOfStartOfDataTraces | file position of start of trace data
Top
See Also

Reference

SEGYlib Namespace
Send comments on this topic to bob.courtney@canada.ca


SEGYFileHeader Constructor

SEGYFileHeader Constructor
constructor

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SEGYFileHeader()
Public Sub New
public:
SEGYFileHeader()
new : unit -> SEGYFileHeader
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader Properties

SEGYFileHeader Properties

The SEGYFileHeader type exposes the following members.

Properties
 | Name | Description
Public property | amplitudeRecoveryMethod | attribute defined though segy rev 1 standard
Public property | BinaryFileHeader | access to byte block of Binary File header
Public property | binaryGainRecovered | attribute defined though segy rev 1 standard
Public property | correlatedDataTraces | attribute defined though segy rev 1 standard
Public property | dataSampleFormatCode | attribute defined though segy rev 1 standard
Public property | ensembleFold | attribute defined though segy rev 1 standard
Public property | ExtendedTextHeader | lead 3200 byte tape header plus any other extended blocks
Public property | fixedLengthTraceFlag | attribute defined though segy rev 1 standard
Public property | impulseSignalPolarity | attribute defined though segy rev 1 standard
Public property | jobIdentificationNumberz | attribute defined though segy rev 1 standard
Public property | lengthOfFileHeader | byte length of file header including extended tape header and binary file header
Public property | lineNumber | attribute defined though segy rev 1 standard
Public property | measurementSystem | attribute defined though segy rev 1 standard
Public property | numberOfAuxilaryTracesPerEnsemble | attribute defined though segy rev 1 standard
Public property | numberOfDataTracesPerEnsemble | attribute defined though segy rev 1 standard
Public property | numberOfExtendedTextualFileHeaderRecordsFollowing | attribute defined though segy rev 1 standard
Public property | numberOfSamplesPerDataTrace | attribute defined though segy rev 1 standard
Public property | numberOfSamplesPerDataTraceForOriginalFieldRecording | attribute defined though segy rev 1 standard
Public property | reelNumber | attribute defined though segy rev 1 standard
Public property | sampleIntervalInMicroseconds | attribute defined though segy rev 1 standard
Public property | sampleIntervalInMicrosecondsInOriginalFieldRecording | attribute defined though segy rev 1 standard
Public property | segyFormatRevisionNumber | attribute defined though segy rev 1 standard
Public property | sweepCode | attribute defined though segy rev 1 standard
Public property | sweepFrequencyEnd | attribute defined though segy rev 1 standard
Public property | sweepFrequencyStart | attribute defined though segy rev 1 standard
Public property | sweepLength | attribute defined though segy rev 1 standard
Public property | sweepTraceTaperLengthAtEnd | attribute defined though segy rev 1 standard
Public property | sweepTraceTaperLengthAtStart | attribute defined though segy rev 1 standard
Public property | taperType | attribute defined though segy rev 1 standard
Public property | traceNumberSweepChannel | attribute defined though segy rev 1 standard
Public property | traceSortingCode | attribute defined though segy rev 1 standard
Public property | verticalSumCode | attribute defined though segy rev 1 standard
Public property | vibratoryPolarityCode | attribute defined though segy rev 1 standard
Top
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.amplitudeRecoveryMethod Property

SEGYFileHeaderamplitudeRecoveryMethod Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort amplitudeRecoveryMethod { get; set; }
Public Property amplitudeRecoveryMethod As UShort
    Get
    Set
public:
property unsigned short amplitudeRecoveryMethod {
    unsigned short get ();
    void set (unsigned short value);
}
member amplitudeRecoveryMethod : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.BinaryFileHeader Property

SEGYFileHeaderBinaryFileHeader Property
access to byte block of Binary File header

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] BinaryFileHeader { get; set; }
Public Property BinaryFileHeader As Byte()
    Get
    Set
public:
property array<unsigned char>^ BinaryFileHeader {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member BinaryFileHeader : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.binaryGainRecovered Property

SEGYFileHeaderbinaryGainRecovered Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort binaryGainRecovered { get; set; }
Public Property binaryGainRecovered As UShort
    Get
    Set
public:
property unsigned short binaryGainRecovered {
    unsigned short get ();
    void set (unsigned short value);
}
member binaryGainRecovered : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.correlatedDataTraces Property

SEGYFileHeadercorrelatedDataTraces Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort correlatedDataTraces { get; set; }
Public Property correlatedDataTraces As UShort
    Get
    Set
public:
property unsigned short correlatedDataTraces {
    unsigned short get ();
    void set (unsigned short value);
}
member correlatedDataTraces : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.dataSampleFormatCode Property

SEGYFileHeaderdataSampleFormatCode Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int dataSampleFormatCode { get; set; }
Public Property dataSampleFormatCode As Integer
    Get
    Set
public:
property int dataSampleFormatCode {
    int get ();
    void set (int value);
}
member dataSampleFormatCode : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.ensembleFold Property

SEGYFileHeaderensembleFold Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort ensembleFold { get; set; }
Public Property ensembleFold As UShort
    Get
    Set
public:
property unsigned short ensembleFold {
    unsigned short get ();
    void set (unsigned short value);
}
member ensembleFold : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.ExtendedTextHeader Property

SEGYFileHeaderExtendedTextHeader Property
lead 3200 byte tape header plus any other extended blocks

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public List<byte[]> ExtendedTextHeader { get; set; }
Public Property ExtendedTextHeader As List(Of Byte())
    Get
    Set
public:
property List<array<unsigned char>^>^ ExtendedTextHeader {
    List<array<unsigned char>^>^ get ();
    void set (List<array<unsigned char>^>^ value);
}
member ExtendedTextHeader : List<byte[]> with get, set

Property Value

Type: List Byte
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.fixedLengthTraceFlag Property

SEGYFileHeaderfixedLengthTraceFlag Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort fixedLengthTraceFlag { get; set; }
Public Property fixedLengthTraceFlag As UShort
    Get
    Set
public:
property unsigned short fixedLengthTraceFlag {
    unsigned short get ();
    void set (unsigned short value);
}
member fixedLengthTraceFlag : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.impulseSignalPolarity Property

SEGYFileHeaderimpulseSignalPolarity Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort impulseSignalPolarity { get; set; }
Public Property impulseSignalPolarity As UShort
    Get
    Set
public:
property unsigned short impulseSignalPolarity {
    unsigned short get ();
    void set (unsigned short value);
}
member impulseSignalPolarity : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.jobIdentificationNumberz Property

SEGYFileHeaderjobIdentificationNumberz Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint jobIdentificationNumberz { get; set; }
Public Property jobIdentificationNumberz As UInteger
    Get
    Set
public:
property unsigned int jobIdentificationNumberz {
    unsigned int get ();
    void set (unsigned int value);
}
member jobIdentificationNumberz : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.lengthOfFileHeader Property

SEGYFileHeaderlengthOfFileHeader Property
byte length of file header including extended tape header and binary file header

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int lengthOfFileHeader { get; set; }
Public Property lengthOfFileHeader As Integer
    Get
    Set
public:
property int lengthOfFileHeader {
    int get ();
    void set (int value);
}
member lengthOfFileHeader : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.lineNumber Property

SEGYFileHeaderlineNumber Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint lineNumber { get; set; }
Public Property lineNumber As UInteger
    Get
    Set
public:
property unsigned int lineNumber {
    unsigned int get ();
    void set (unsigned int value);
}
member lineNumber : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.measurementSystem Property

SEGYFileHeadermeasurementSystem Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort measurementSystem { get; set; }
Public Property measurementSystem As UShort
    Get
    Set
public:
property unsigned short measurementSystem {
    unsigned short get ();
    void set (unsigned short value);
}
member measurementSystem : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.numberOfAuxilaryTracesPerEnsemble Property

SEGYFileHeadernumberOfAuxilaryTracesPerEnsemble Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort numberOfAuxilaryTracesPerEnsemble { get; set; }
Public Property numberOfAuxilaryTracesPerEnsemble As UShort
    Get
    Set
public:
property unsigned short numberOfAuxilaryTracesPerEnsemble {
    unsigned short get ();
    void set (unsigned short value);
}
member numberOfAuxilaryTracesPerEnsemble : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.numberOfDataTracesPerEnsemble Property

SEGYFileHeadernumberOfDataTracesPerEnsemble Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort numberOfDataTracesPerEnsemble { get; set; }
Public Property numberOfDataTracesPerEnsemble As UShort
    Get
    Set
public:
property unsigned short numberOfDataTracesPerEnsemble {
    unsigned short get ();
    void set (unsigned short value);
}
member numberOfDataTracesPerEnsemble : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.numberOfExtendedTextualFileHeaderRecordsFollowing Property

SEGYFileHeadernumberOfExtendedTextualFileHeaderRecordsFollowing Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort numberOfExtendedTextualFileHeaderRecordsFollowing { get; set; }
Public Property numberOfExtendedTextualFileHeaderRecordsFollowing As UShort
    Get
    Set
public:
property unsigned short numberOfExtendedTextualFileHeaderRecordsFollowing {
    unsigned short get ();
    void set (unsigned short value);
}
member numberOfExtendedTextualFileHeaderRecordsFollowing : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.numberOfSamplesPerDataTrace Property

SEGYFileHeadernumberOfSamplesPerDataTrace Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort numberOfSamplesPerDataTrace { get; set; }
Public Property numberOfSamplesPerDataTrace As UShort
    Get
    Set
public:
property unsigned short numberOfSamplesPerDataTrace {
    unsigned short get ();
    void set (unsigned short value);
}
member numberOfSamplesPerDataTrace : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.numberOfSamplesPerDataTraceForOriginalFieldRecording Property

SEGYFileHeadernumberOfSamplesPerDataTraceForOriginalFieldRecording Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort numberOfSamplesPerDataTraceForOriginalFieldRecording { get; set; }
Public Property numberOfSamplesPerDataTraceForOriginalFieldRecording As UShort
    Get
    Set
public:
property unsigned short numberOfSamplesPerDataTraceForOriginalFieldRecording {
    unsigned short get ();
    void set (unsigned short value);
}
member numberOfSamplesPerDataTraceForOriginalFieldRecording : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.reelNumber Property

SEGYFileHeaderreelNumber Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint reelNumber { get; set; }
Public Property reelNumber As UInteger
    Get
    Set
public:
property unsigned int reelNumber {
    unsigned int get ();
    void set (unsigned int value);
}
member reelNumber : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.sampleIntervalInMicroseconds Property

SEGYFileHeadersampleIntervalInMicroseconds Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort sampleIntervalInMicroseconds { get; set; }
Public Property sampleIntervalInMicroseconds As UShort
    Get
    Set
public:
property unsigned short sampleIntervalInMicroseconds {
    unsigned short get ();
    void set (unsigned short value);
}
member sampleIntervalInMicroseconds : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.sampleIntervalInMicrosecondsInOriginalFieldRecording Property

SEGYFileHeadersampleIntervalInMicrosecondsInOriginalFieldRecording Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort sampleIntervalInMicrosecondsInOriginalFieldRecording { get; set; }
Public Property sampleIntervalInMicrosecondsInOriginalFieldRecording As UShort
    Get
    Set
public:
property unsigned short sampleIntervalInMicrosecondsInOriginalFieldRecording {
    unsigned short get ();
    void set (unsigned short value);
}
member sampleIntervalInMicrosecondsInOriginalFieldRecording : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.segyFormatRevisionNumber Property

SEGYFileHeadersegyFormatRevisionNumber Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort segyFormatRevisionNumber { get; set; }
Public Property segyFormatRevisionNumber As UShort
    Get
    Set
public:
property unsigned short segyFormatRevisionNumber {
    unsigned short get ();
    void set (unsigned short value);
}
member segyFormatRevisionNumber : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.sweepCode Property

SEGYFileHeadersweepCode Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort sweepCode { get; set; }
Public Property sweepCode As UShort
    Get
    Set
public:
property unsigned short sweepCode {
    unsigned short get ();
    void set (unsigned short value);
}
member sweepCode : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.sweepFrequencyEnd Property

SEGYFileHeadersweepFrequencyEnd Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort sweepFrequencyEnd { get; set; }
Public Property sweepFrequencyEnd As UShort
    Get
    Set
public:
property unsigned short sweepFrequencyEnd {
    unsigned short get ();
    void set (unsigned short value);
}
member sweepFrequencyEnd : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.sweepFrequencyStart Property

SEGYFileHeadersweepFrequencyStart Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort sweepFrequencyStart { get; set; }
Public Property sweepFrequencyStart As UShort
    Get
    Set
public:
property unsigned short sweepFrequencyStart {
    unsigned short get ();
    void set (unsigned short value);
}
member sweepFrequencyStart : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.sweepLength Property

SEGYFileHeadersweepLength Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort sweepLength { get; set; }
Public Property sweepLength As UShort
    Get
    Set
public:
property unsigned short sweepLength {
    unsigned short get ();
    void set (unsigned short value);
}
member sweepLength : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.sweepTraceTaperLengthAtEnd Property

SEGYFileHeadersweepTraceTaperLengthAtEnd Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort sweepTraceTaperLengthAtEnd { get; set; }
Public Property sweepTraceTaperLengthAtEnd As UShort
    Get
    Set
public:
property unsigned short sweepTraceTaperLengthAtEnd {
    unsigned short get ();
    void set (unsigned short value);
}
member sweepTraceTaperLengthAtEnd : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.sweepTraceTaperLengthAtStart Property

SEGYFileHeadersweepTraceTaperLengthAtStart Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort sweepTraceTaperLengthAtStart { get; set; }
Public Property sweepTraceTaperLengthAtStart As UShort
    Get
    Set
public:
property unsigned short sweepTraceTaperLengthAtStart {
    unsigned short get ();
    void set (unsigned short value);
}
member sweepTraceTaperLengthAtStart : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.taperType Property

SEGYFileHeadertaperType Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort taperType { get; set; }
Public Property taperType As UShort
    Get
    Set
public:
property unsigned short taperType {
    unsigned short get ();
    void set (unsigned short value);
}
member taperType : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.traceNumberSweepChannel Property

SEGYFileHeadertraceNumberSweepChannel Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort traceNumberSweepChannel { get; set; }
Public Property traceNumberSweepChannel As UShort
    Get
    Set
public:
property unsigned short traceNumberSweepChannel {
    unsigned short get ();
    void set (unsigned short value);
}
member traceNumberSweepChannel : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.traceSortingCode Property

SEGYFileHeadertraceSortingCode Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short traceSortingCode { get; set; }
Public Property traceSortingCode As Short
    Get
    Set
public:
property short traceSortingCode {
    short get ();
    void set (short value);
}
member traceSortingCode : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.verticalSumCode Property

SEGYFileHeaderverticalSumCode Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort verticalSumCode { get; set; }
Public Property verticalSumCode As UShort
    Get
    Set
public:
property unsigned short verticalSumCode {
    unsigned short get ();
    void set (unsigned short value);
}
member verticalSumCode : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.vibratoryPolarityCode Property

SEGYFileHeadervibratoryPolarityCode Property
attribute defined though segy rev 1 standard

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort vibratoryPolarityCode { get; set; }
Public Property vibratoryPolarityCode As UShort
    Get
    Set
public:
property unsigned short vibratoryPolarityCode {
    unsigned short get ();
    void set (unsigned short value);
}
member vibratoryPolarityCode : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader Methods

SEGYFileHeader Methods

The SEGYFileHeader type exposes the following members.

Methods
 | Name | Description
Public method | Copy | make a deep copy of the Header
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFileHeaderText | get a string for the extended tape header
Public method | GetFileHeaderTextByLine | get the Text header by 80 character lines
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | isBigEndian | true for big endian and false for little endian
Public method | isFileHeaderASCII | is the file header encoded with ASCII or EBCDIC
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadFileHeader | read the file header from disk
Public method | SetFileHeader | set the Text Header by 80 character line
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteFileHeader | write the file header to disk
Top
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.Copy Method

SEGYFileHeaderCopy Method
make a deep copy of the Header

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SEGYFileHeader Copy()
Public Function Copy As SEGYFileHeader
public:
SEGYFileHeader^ Copy()
member Copy : unit -> SEGYFileHeader

Return Value

Type: SEGYFileHeader
a deep copy of the SEGYFileHeader structure
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.GetFileHeaderText Method

SEGYFileHeaderGetFileHeaderText Method
get a string for the extended tape header

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetFileHeaderText(
    int block
)
Public Function GetFileHeaderText (
    block As Integer
) As String
public:
String^ GetFileHeaderText(
    int block
)
member GetFileHeaderText :
        block : int -> string

Parameters

block
Type: SystemInt32
extended trace header block number

Return Value

Type: String
a 3200 character string ; null if the block number is invalid
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.GetFileHeaderTextByLine Method

SEGYFileHeaderGetFileHeaderTextByLine Method
get the Text header by 80 character lines

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetFileHeaderTextByLine(
    int block,
    int line
)
Public Function GetFileHeaderTextByLine (
    block As Integer,
    line As Integer
) As String
public:
String^ GetFileHeaderTextByLine(
    int block,
    int line
)
member GetFileHeaderTextByLine :
        block : int *
        line : int -> string

Parameters

block
Type: SystemInt32
extended trace header block number
line
Type: SystemInt32
linb number ( 0 to 39)

Return Value

Type: String
an 80 character string ; null if the block number is invalid
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.isBigEndian Method

SEGYFileHeaderisBigEndian Method
true for big endian and false for little endian

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool isBigEndian()
Public Function isBigEndian As Boolean
public:
bool isBigEndian()
member isBigEndian : unit -> bool

Return Value

Type: Boolean
true if the file header is big endian
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.isFileHeaderASCII Method

SEGYFileHeaderisFileHeaderASCII Method
is the file header encoded with ASCII or EBCDIC

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool isFileHeaderASCII()
Public Function isFileHeaderASCII As Boolean
public:
bool isFileHeaderASCII()
member isFileHeaderASCII : unit -> bool

Return Value

Type: Boolean
true if file header text is ASCII formatted
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.ReadFileHeader Method

SEGYFileHeaderReadFileHeader Method
read the file header from disk

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReadFileHeader(
    BinaryReader br
)
Public Function ReadFileHeader (
    br As BinaryReader
) As Boolean
public:
bool ReadFileHeader(
    BinaryReader^ br
)
member ReadFileHeader :
        br : BinaryReader -> bool

Parameters

br
Type: System.IOBinaryReader
binary reader stream

Return Value

Type: Boolean
true if successful
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.SetFileHeader Method

SEGYFileHeaderSetFileHeader Method
set the Text Header by 80 character line

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFileHeader(
    int block,
    int line,
    string str
)
Public Sub SetFileHeader (
    block As Integer,
    line As Integer,
    str As String
)
public:
void SetFileHeader(
    int block,
    int line,
    String^ str
)
member SetFileHeader :
        block : int *
        line : int *
        str : string -> unit

Parameters

block
Type: SystemInt32
extended block number
line
Type: SystemInt32
line number ( 0 to 39)
str
Type: SystemString
input string
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.WriteFileHeader Method

SEGYFileHeaderWriteFileHeader Method
write the file header to disk

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool WriteFileHeader(
    BinaryWriter bw
)
Public Function WriteFileHeader (
    bw As BinaryWriter
) As Boolean
public:
bool WriteFileHeader(
    BinaryWriter^ bw
)
member WriteFileHeader :
        bw : BinaryWriter -> bool

Parameters

bw
Type: System.IOBinaryWriter
output binary writer stream

Return Value

Type: Boolean
true if successful
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader Fields

SEGYFileHeader Fields

The SEGYFileHeader type exposes the following members.

Fields
 | Name | Description
Public field | isSEGYFileHeaderAscii | true if Text Header is ASCII; false if EBCDIC
Public field | positionOfStartOfDataTraces | file position of start of trace data
Top
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.isSEGYFileHeaderAscii Field

SEGYFileHeaderisSEGYFileHeaderAscii Field
true if Text Header is ASCII; false if EBCDIC

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool isSEGYFileHeaderAscii
Public isSEGYFileHeaderAscii As Boolean
public:
bool isSEGYFileHeaderAscii
val mutable isSEGYFileHeaderAscii: bool

Field Value

Type: Boolean
See Also

Reference

SEGYFileHeader Class


SEGYFileHeader.positionOfStartOfDataTraces Field

SEGYFileHeaderpositionOfStartOfDataTraces Field
file position of start of trace data

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long positionOfStartOfDataTraces
Public positionOfStartOfDataTraces As Long
public:
long long positionOfStartOfDataTraces
val mutable positionOfStartOfDataTraces: int64

Field Value

Type: Int64
See Also

Reference

SEGYFileHeader Class


SEGYTrace Class

SEGYTrace Class
SEGYTrace is used to access and set SEGY rev 1 trace data
Inheritance Hierarchy
SystemObject
SEGYlibSEGYTrace

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SEGYTrace
Public Class SEGYTrace
public ref class SEGYTrace
type SEGYTrace =  class end

The SEGYTrace type exposes the following members.

Constructors
 | Name | Description
Public method | SEGYTrace | constructor
Top
Properties
 | Name | Description
Public property | codedTime | trace time in DDDHHHMMSSmmm
Public property | Data | signal amplitude
Public property | groupPositionXGSCDIG | GSCA implemententation of group position
Public property | groupPositionYGSCDIG | GSCA implemententation of group position
Public property | isBigEndian | true if big endian
Public property | isLatLon | is it a lat/lon position or projected
Public property | positionOfTraceInFile | position in bytes
Public property | sourcePositionX | source position X corrected for scaling factors
Public property | sourcePositionY | source position Y corrected for scaling factors
Public property | timeTracedRecorded | DateTime of trace instance
Public property | totalLengthOfTraceData | total number of bytes of trace data in including trace header
Public property | TraceData | access to underlying Trace Data Class
Public property | TraceHeader | access to underlying Trace Header Class
Top
Methods
 | Name | Description
Public method | Copy | make a deep copy of a SEGY Trace
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FixMsecField | transcribe msec field in old GSC format the old GSC formatted files used the Time Basis Field 166-167 for storing msec field should use lag b or lag A field this copies 166-167 to 106-107
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intialize | initilize trace structure
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | write a trace to a BinaryWriter stream
Top
See Also

Reference

SEGYlib Namespace
Send comments on this topic to bob.courtney@canada.ca


SEGYTrace Constructor

SEGYTrace Constructor
constructor

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SEGYTrace()
Public Sub New
public:
SEGYTrace()
new : unit -> SEGYTrace
See Also

Reference

SEGYTrace Class


SEGYTrace Properties

SEGYTrace Properties

The SEGYTrace type exposes the following members.

Properties
 | Name | Description
Public property | codedTime | trace time in DDDHHHMMSSmmm
Public property | Data | signal amplitude
Public property | groupPositionXGSCDIG | GSCA implemententation of group position
Public property | groupPositionYGSCDIG | GSCA implemententation of group position
Public property | isBigEndian | true if big endian
Public property | isLatLon | is it a lat/lon position or projected
Public property | positionOfTraceInFile | position in bytes
Public property | sourcePositionX | source position X corrected for scaling factors
Public property | sourcePositionY | source position Y corrected for scaling factors
Public property | timeTracedRecorded | DateTime of trace instance
Public property | totalLengthOfTraceData | total number of bytes of trace data in including trace header
Public property | TraceData | access to underlying Trace Data Class
Public property | TraceHeader | access to underlying Trace Header Class
Top
See Also

Reference

SEGYTrace Class


SEGYTrace.codedTime Property

SEGYTracecodedTime Property
trace time in DDDHHHMMSSmmm

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long codedTime { get; set; }
Public Property codedTime As Long
    Get
    Set
public:
property long long codedTime {
    long long get ();
    void set (long long value);
}
member codedTime : int64 with get, set

Property Value

Type: Int64
See Also

Reference

SEGYTrace Class


SEGYTrace.Data Property

SEGYTraceData Property
signal amplitude

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double[] Data { get; set; }
Public Property Data As Double()
    Get
    Set
public:
property array<double>^ Data {
    array<double>^ get ();
    void set (array<double>^ value);
}
member Data : float[] with get, set

Property Value

Type: Double
See Also

Reference

SEGYTrace Class


SEGYTrace.groupPositionXGSCDIG Property

SEGYTracegroupPositionXGSCDIG Property
GSCA implemententation of group position

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double groupPositionXGSCDIG { get; set; }
Public Property groupPositionXGSCDIG As Double
    Get
    Set
public:
property double groupPositionXGSCDIG {
    double get ();
    void set (double value);
}
member groupPositionXGSCDIG : float with get, set

Property Value

Type: Double
See Also

Reference

SEGYTrace Class


SEGYTrace.groupPositionYGSCDIG Property

SEGYTracegroupPositionYGSCDIG Property
GSCA implemententation of group position

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double groupPositionYGSCDIG { get; set; }
Public Property groupPositionYGSCDIG As Double
    Get
    Set
public:
property double groupPositionYGSCDIG {
    double get ();
    void set (double value);
}
member groupPositionYGSCDIG : float with get, set

Property Value

Type: Double
See Also

Reference

SEGYTrace Class


SEGYTrace.isBigEndian Property

SEGYTraceisBigEndian Property
true if big endian

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool isBigEndian { get; set; }
Public Property isBigEndian As Boolean
    Get
    Set
public:
property bool isBigEndian {
    bool get ();
    void set (bool value);
}
member isBigEndian : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SEGYTrace Class


SEGYTrace.isLatLon Property

SEGYTraceisLatLon Property
is it a lat/lon position or projected

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool isLatLon { get; set; }
Public Property isLatLon As Boolean
    Get
    Set
public:
property bool isLatLon {
    bool get ();
    void set (bool value);
}
member isLatLon : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SEGYTrace Class


SEGYTrace.positionOfTraceInFile Property

SEGYTracepositionOfTraceInFile Property
position in bytes

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long positionOfTraceInFile { get; set; }
Public Property positionOfTraceInFile As Long
    Get
    Set
public:
property long long positionOfTraceInFile {
    long long get ();
    void set (long long value);
}
member positionOfTraceInFile : int64 with get, set

Property Value

Type: Int64
See Also

Reference

SEGYTrace Class


SEGYTrace.sourcePositionX Property

SEGYTracesourcePositionX Property
source position X corrected for scaling factors

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double sourcePositionX { get; set; }
Public Property sourcePositionX As Double
    Get
    Set
public:
property double sourcePositionX {
    double get ();
    void set (double value);
}
member sourcePositionX : float with get, set

Property Value

Type: Double
See Also

Reference

SEGYTrace Class


SEGYTrace.sourcePositionY Property

SEGYTracesourcePositionY Property
source position Y corrected for scaling factors

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double sourcePositionY { get; set; }
Public Property sourcePositionY As Double
    Get
    Set
public:
property double sourcePositionY {
    double get ();
    void set (double value);
}
member sourcePositionY : float with get, set

Property Value

Type: Double
See Also

Reference

SEGYTrace Class


SEGYTrace.timeTracedRecorded Property

SEGYTracetimeTracedRecorded Property
DateTime of trace instance

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime timeTracedRecorded { get; set; }
Public Property timeTracedRecorded As DateTime
    Get
    Set
public:
property DateTime timeTracedRecorded {
    DateTime get ();
    void set (DateTime value);
}
member timeTracedRecorded : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

SEGYTrace Class


SEGYTrace.totalLengthOfTraceData Property

SEGYTracetotalLengthOfTraceData Property
total number of bytes of trace data in including trace header

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int totalLengthOfTraceData { get; set; }
Public Property totalLengthOfTraceData As Integer
    Get
    Set
public:
property int totalLengthOfTraceData {
    int get ();
    void set (int value);
}
member totalLengthOfTraceData : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYTrace Class


SEGYTrace.TraceData Property

SEGYTraceTraceData Property
access to underlying Trace Data Class

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SEGYTraceData TraceData { get; set; }
Public Property TraceData As SEGYTraceData
    Get
    Set
public:
property SEGYTraceData^ TraceData {
    SEGYTraceData^ get ();
    void set (SEGYTraceData^ value);
}
member TraceData : SEGYTraceData with get, set

Property Value

Type: SEGYTraceData
See Also

Reference

SEGYTrace Class


SEGYTrace.TraceHeader Property

SEGYTraceTraceHeader Property
access to underlying Trace Header Class

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SEGYTraceHeader TraceHeader { get; set; }
Public Property TraceHeader As SEGYTraceHeader
    Get
    Set
public:
property SEGYTraceHeader^ TraceHeader {
    SEGYTraceHeader^ get ();
    void set (SEGYTraceHeader^ value);
}
member TraceHeader : SEGYTraceHeader with get, set

Property Value

Type: SEGYTraceHeader
See Also

Reference

SEGYTrace Class


SEGYTrace Methods

SEGYTrace Methods

The SEGYTrace type exposes the following members.

Methods
 | Name | Description
Public method | Copy | make a deep copy of a SEGY Trace
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FixMsecField | transcribe msec field in old GSC format the old GSC formatted files used the Time Basis Field 166-167 for storing msec field should use lag b or lag A field this copies 166-167 to 106-107
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intialize | initilize trace structure
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | write a trace to a BinaryWriter stream
Top
See Also

Reference

SEGYTrace Class


SEGYTrace.Copy Method

SEGYTraceCopy Method
make a deep copy of a SEGY Trace

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SEGYTrace Copy()
Public Function Copy As SEGYTrace
public:
SEGYTrace^ Copy()
member Copy : unit -> SEGYTrace

Return Value

Type: SEGYTrace
pointer to a deep copy of the input trace
See Also

Reference

SEGYTrace Class


SEGYTrace.FixMsecField Method

SEGYTraceFixMsecField Method
transcribe msec field in old GSC format the old GSC formatted files used the Time Basis Field 166-167 for storing msec field should use lag b or lag A field this copies 166-167 to 106-107

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void FixMsecField()
Public Sub FixMsecField
public:
void FixMsecField()
member FixMsecField : unit -> unit
See Also

Reference

SEGYTrace Class


SEGYTrace.Intialize Method

SEGYTraceIntialize Method
initilize trace structure

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Intialize(
    bool isBigEndian,
    int format
)
Public Sub Intialize (
    isBigEndian As Boolean,
    format As Integer
)
public:
void Intialize(
    bool isBigEndian,
    int format
)
member Intialize :
        isBigEndian : bool *
        format : int -> unit

Parameters

isBigEndian
Type: SystemBoolean
is the file big endian or little endian
format
Type: SystemInt32
format of data word length according to SEGY standard
See Also

Reference

SEGYTrace Class


SEGYTrace.Write Method

SEGYTraceWrite Method
write a trace to a BinaryWriter stream

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Write(
    BinaryWriter bw
)
Public Function Write (
    bw As BinaryWriter
) As Boolean
public:
bool Write(
    BinaryWriter^ bw
)
member Write :
        bw : BinaryWriter -> bool

Parameters

bw
Type: System.IOBinaryWriter
output stream pointer

Return Value

Type: Boolean
true if successful
See Also

Reference

SEGYTrace Class


SEGYTraceData Class

SEGYTraceData Class
SEGYTraceData allows access to the contents of the binary trace data
Inheritance Hierarchy
SystemObject
SEGYlibSEGYTraceData

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SEGYTraceData
Public Class SEGYTraceData
public ref class SEGYTraceData
type SEGYTraceData =  class end

The SEGYTraceData type exposes the following members.

Constructors
 | Name | Description
Public method | SEGYTraceData | SEGYTraceData allows access to the contents of the binary trace data
Top
Properties
 | Name | Description
Public property | Data | a double precision view of the trace data use this to read and change the contents of the trace data buffer
Public property | DataCopy | Use this if you want to change the data values as SEGYTraceData.Data always returns values in the trace data buffer
Public property | TraceDataBuffer | access to byte[] trace data block
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initialize the class
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SEGYlib Namespace
Send comments on this topic to bob.courtney@canada.ca


SEGYTraceData Constructor

SEGYTraceData Constructor
SEGYTraceData allows access to the contents of the binary trace data

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SEGYTraceData()
Public Sub New
public:
SEGYTraceData()
new : unit -> SEGYTraceData
See Also

Reference

SEGYTraceData Class


SEGYTraceData Properties

SEGYTraceData Properties

The SEGYTraceData type exposes the following members.

Properties
 | Name | Description
Public property | Data | a double precision view of the trace data use this to read and change the contents of the trace data buffer
Public property | DataCopy | Use this if you want to change the data values as SEGYTraceData.Data always returns values in the trace data buffer
Public property | TraceDataBuffer | access to byte[] trace data block
Top
See Also

Reference

SEGYTraceData Class


SEGYTraceData.Data Property

SEGYTraceDataData Property
a double precision view of the trace data use this to read and change the contents of the trace data buffer

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double[] Data { get; set; }
Public Property Data As Double()
    Get
    Set
public:
property array<double>^ Data {
    array<double>^ get ();
    void set (array<double>^ value);
}
member Data : float[] with get, set

Property Value

Type: Double
See Also

Reference

SEGYTraceData Class


SEGYTraceData.DataCopy Property

SEGYTraceDataDataCopy Property
Use this if you want to change the data values as SEGYTraceData.Data always returns values in the trace data buffer

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double[] DataCopy { get; set; }
Public Property DataCopy As Double()
    Get
    Set
public:
property array<double>^ DataCopy {
    array<double>^ get ();
    void set (array<double>^ value);
}
member DataCopy : float[] with get, set

Property Value

Type: Double
See Also

Reference

SEGYTraceData Class


SEGYTraceData.TraceDataBuffer Property

SEGYTraceDataTraceDataBuffer Property
access to byte[] trace data block

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] TraceDataBuffer { get; set; }
Public Property TraceDataBuffer As Byte()
    Get
    Set
public:
property array<unsigned char>^ TraceDataBuffer {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member TraceDataBuffer : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

SEGYTraceData Class


SEGYTraceData Methods

SEGYTraceData Methods

The SEGYTraceData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initialize the class
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SEGYTraceData Class


SEGYTraceData.Initialize Method

SEGYTraceDataInitialize Method
Initialize the class

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Initialize(
    int format,
    bool bigendian
)
Public Sub Initialize (
    format As Integer,
    bigendian As Boolean
)
public:
void Initialize(
    int format,
    bool bigendian
)
member Initialize :
        format : int *
        bigendian : bool -> unit

Parameters

format
Type: SystemInt32
segy rev 1 data format
bigendian
Type: SystemBoolean
true if data is big endian
See Also

Reference

SEGYTraceData Class


SEGYTraceHeader Class

SEGYTraceHeader Class
SEGYTraceHeader is used to access and change contents of the binary trace header data block
Inheritance Hierarchy
SystemObject
SEGYlibSEGYTraceHeader

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SEGYTraceHeader
Public Class SEGYTraceHeader
public ref class SEGYTraceHeader
type SEGYTraceHeader =  class end

The SEGYTraceHeader type exposes the following members.

Constructors
 | Name | Description
Public method | SEGYTraceHeader | SEGYTraceHeader is used to access and change contents of the binary trace header data block
Top
Properties
 | Name | Description
Public property | aliasFilterSlopeDBOctave | refer to SEGY rev 1 documentation
Public property | aliasFrequencyHz | refer to SEGY rev 1 documentation
Public property | bigEndian | true if big endian
Public property | coordinateUnits | refer to SEGY rev 1 documentation
Public property | correlated | refer to SEGY rev 1 documentation
Public property | crossLineNumber3D | refer to SEGY rev 1 documentation
Public property | dataUse | refer to SEGY rev 1 documentation
Public property | datumElevationAtReceiverGroup | refer to SEGY rev 1 documentation
Public property | datumElevationAtSource | refer to SEGY rev 1 documentation
Public property | dayOfYear | refer to SEGY rev 1 documentation
Public property | delayRecordingTimeMsec | refer to SEGY rev 1 documentation
Public property | deviceTraceIdentifier | refer to SEGY rev 1 documentation
Public property | distanceFromCenterOfSourcePointToCenterOfGroup | refer to SEGY rev 1 documentation
Public property | energySourcePointNumber | refer to SEGY rev 1 documentation
Public property | ensembleNumber | refer to SEGY rev 1 documentation
Public property | gainTypeOfFieldInstruments | refer to SEGY rev 1 documentation
Public property | gapSize | refer to SEGY rev 1 documentation
Public property | geophoneGroupNumberofLastTraceWithinOriginalFieldRecord | refer to SEGY rev 1 documentation
Public property | geophoneGroupNumberOfRollSwitchPositionOne | refer to SEGY rev 1 documentation
Public property | geophoneGroupNumberofTraceNumberOneWithinOriginalFieldRecord | refer to SEGY rev 1 documentation
Public property | groupCoordinateX | refer to SEGY rev 1 documentation
Public property | groupCoordinateY | refer to SEGY rev 1 documentation
Public property | groupStaticCorrectionMsec | refer to SEGY rev 1 documentation
Public property | highCutFrequencyHz | refer to SEGY rev 1 documentation
Public property | highCutSlopeDBOctave | refer to SEGY rev 1 documentation
Public property | hourOfDay | refer to SEGY rev 1 documentation
Public property | inLineNumber3D | refer to SEGY rev 1 documentation
Public property | instrumentEarlyOrIntialGainDB | refer to SEGY rev 1 documentation
Public property | instrumentGainConstantDB | refer to SEGY rev 1 documentation
Public property | lagTimeAMsec | refer to SEGY rev 1 documentation
Public property | lagTimeBMsec | refer to SEGY rev 1 documentation
Public property | lowCutFrequencyHz | refer to SEGY rev 1 documentation
Public property | lowCutSlopeDBOctave | refer to SEGY rev 1 documentation
Public property | minuteOfHour | refer to SEGY rev 1 documentation
Public property | muteTimeEndTimeMsec | refer to SEGY rev 1 documentation
Public property | muteTimeStartTimeMsec | refer to SEGY rev 1 documentation
Public property | notchFilterSlopeDBOctave | refer to SEGY rev 1 documentation
Public property | notchFrequencyHz | refer to SEGY rev 1 documentation
Public property | numberOfHorizonatallySummedTracesYieldingThisTrace | refer to SEGY rev 1 documentation
Public property | numberOfSamplesInTrace | refer to SEGY rev 1 documentation
Public property | numberOfVerticallySummedTracesYieldingThisTrace | refer to SEGY rev 1 documentation
Public property | originalFieldRecordNumber | refer to SEGY rev 1 documentation
Public property | overTravel | refer to SEGY rev 1 documentation
Public property | receiverGroupElevation | refer to SEGY rev 1 documentation
Public property | sampleIntervalUsec | refer to SEGY rev 1 documentation
Public property | scalarAppliedToShotPointNumber | refer to SEGY rev 1 documentation
Public property | scalarForAllElevationsAndDepths | refer to SEGY rev 1 documentation
Public property | scalarToBeAppliedToAllCoordinates | refer to SEGY rev 1 documentation
Public property | scalarUsedToScaleTraceHeaderMSecTimes | refer to SEGY rev 1 documentation
Public property | secondOfMinute | refer to SEGY rev 1 documentation
Public property | shotpointNumber | refer to SEGY rev 1 documentation
Public property | souceStaticCorrectionMsec | refer to SEGY rev 1 documentation
Public property | sourceCoordinateX | refer to SEGY rev 1 documentation
Public property | sourceCoordinateY | refer to SEGY rev 1 documentation
Public property | sourceDepthBelowSurface | refer to SEGY rev 1 documentation
Public property | sourceEnergyDirectionExponent | refer to SEGY rev 1 documentation
Public property | sourceEnergyDirectionMantissa | refer to SEGY rev 1 documentation
Public property | sourceMeasurementExponent | refer to SEGY rev 1 documentation
Public property | sourceMeasurementMantissa | refer to SEGY rev 1 documentation
Public property | sourceMeasurementUnit | refer to SEGY rev 1 documentation
Public property | sourceType | refer to SEGY rev 1 documentation
Public property | subweatheringVelocity | refer to SEGY rev 1 documentation
Public property | surfaceElevationAtSource | refer to SEGY rev 1 documentation
Public property | sweepFrequencyAtEnd | refer to SEGY rev 1 documentation
Public property | sweepFrequencyAtStart | refer to SEGY rev 1 documentation
Public property | sweepLengthInMsec | refer to SEGY rev 1 documentation
Public property | sweepTaperLenghtAtEndMsec | refer to SEGY rev 1 documentation
Public property | sweepTaperLengthAtStartMsec | refer to SEGY rev 1 documentation
Public property | sweepType | refer to SEGY rev 1 documentation
Public property | taperType | refer to SEGY rev 1 documentation
Public property | timeBasis | refer to SEGY rev 1 documentation
Public property | totalStaticMsec | refer to SEGY rev 1 documentation
Public property | TraceHeaderBuffer | SEGYTraceHeader storage block
Public property | traceIdentificationCode | refer to SEGY rev 1 documentation
Public property | traceNumberWithinEnsemble | refer to SEGY rev 1 documentation
Public property | traceNumberWithinOriginalFieldRecord | refer to SEGY rev 1 documentation
Public property | traceSequenceNumberWithinFile | refer to SEGY rev 1 documentation
Public property | traceSequenceNumberWithinLine | refer to SEGY rev 1 documentation
Public property | traceValueMeasurementUnit | refer to SEGY rev 1 documentation
Public property | traceWeightingFactor | refer to SEGY rev 1 documentation
Public property | transductionConstantExponent | refer to SEGY rev 1 documentation
Public property | transductionConstantMantissa | refer to SEGY rev 1 documentation
Public property | transductionUnits | refer to SEGY rev 1 documentation
Public property | upholeTimeAtGroupMsec | refer to SEGY rev 1 documentation
Public property | upholeTimeAtSourceMsec | refer to SEGY rev 1 documentation
Public property | waterDepthAtGroup | refer to SEGY rev 1 documentation
Public property | waterDepthAtSource | refer to SEGY rev 1 documentation
Public property | weatheringVelocity | refer to SEGY rev 1 documentation
Public property | xCoordinateOfEnsemble | refer to SEGY rev 1 documentation
Public property | yCoordinateOfEnsemble | refer to SEGY rev 1 documentation
Public property | yearDataRecorded | refer to SEGY rev 1 documentation
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | initialize object
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SEGYlib Namespace
Send comments on this topic to bob.courtney@canada.ca


SEGYTraceHeader Constructor

SEGYTraceHeader Constructor
SEGYTraceHeader is used to access and change contents of the binary trace header data block

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SEGYTraceHeader()
Public Sub New
public:
SEGYTraceHeader()
new : unit -> SEGYTraceHeader
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader Properties

SEGYTraceHeader Properties

The SEGYTraceHeader type exposes the following members.

Properties
 | Name | Description
Public property | aliasFilterSlopeDBOctave | refer to SEGY rev 1 documentation
Public property | aliasFrequencyHz | refer to SEGY rev 1 documentation
Public property | bigEndian | true if big endian
Public property | coordinateUnits | refer to SEGY rev 1 documentation
Public property | correlated | refer to SEGY rev 1 documentation
Public property | crossLineNumber3D | refer to SEGY rev 1 documentation
Public property | dataUse | refer to SEGY rev 1 documentation
Public property | datumElevationAtReceiverGroup | refer to SEGY rev 1 documentation
Public property | datumElevationAtSource | refer to SEGY rev 1 documentation
Public property | dayOfYear | refer to SEGY rev 1 documentation
Public property | delayRecordingTimeMsec | refer to SEGY rev 1 documentation
Public property | deviceTraceIdentifier | refer to SEGY rev 1 documentation
Public property | distanceFromCenterOfSourcePointToCenterOfGroup | refer to SEGY rev 1 documentation
Public property | energySourcePointNumber | refer to SEGY rev 1 documentation
Public property | ensembleNumber | refer to SEGY rev 1 documentation
Public property | gainTypeOfFieldInstruments | refer to SEGY rev 1 documentation
Public property | gapSize | refer to SEGY rev 1 documentation
Public property | geophoneGroupNumberofLastTraceWithinOriginalFieldRecord | refer to SEGY rev 1 documentation
Public property | geophoneGroupNumberOfRollSwitchPositionOne | refer to SEGY rev 1 documentation
Public property | geophoneGroupNumberofTraceNumberOneWithinOriginalFieldRecord | refer to SEGY rev 1 documentation
Public property | groupCoordinateX | refer to SEGY rev 1 documentation
Public property | groupCoordinateY | refer to SEGY rev 1 documentation
Public property | groupStaticCorrectionMsec | refer to SEGY rev 1 documentation
Public property | highCutFrequencyHz | refer to SEGY rev 1 documentation
Public property | highCutSlopeDBOctave | refer to SEGY rev 1 documentation
Public property | hourOfDay | refer to SEGY rev 1 documentation
Public property | inLineNumber3D | refer to SEGY rev 1 documentation
Public property | instrumentEarlyOrIntialGainDB | refer to SEGY rev 1 documentation
Public property | instrumentGainConstantDB | refer to SEGY rev 1 documentation
Public property | lagTimeAMsec | refer to SEGY rev 1 documentation
Public property | lagTimeBMsec | refer to SEGY rev 1 documentation
Public property | lowCutFrequencyHz | refer to SEGY rev 1 documentation
Public property | lowCutSlopeDBOctave | refer to SEGY rev 1 documentation
Public property | minuteOfHour | refer to SEGY rev 1 documentation
Public property | muteTimeEndTimeMsec | refer to SEGY rev 1 documentation
Public property | muteTimeStartTimeMsec | refer to SEGY rev 1 documentation
Public property | notchFilterSlopeDBOctave | refer to SEGY rev 1 documentation
Public property | notchFrequencyHz | refer to SEGY rev 1 documentation
Public property | numberOfHorizonatallySummedTracesYieldingThisTrace | refer to SEGY rev 1 documentation
Public property | numberOfSamplesInTrace | refer to SEGY rev 1 documentation
Public property | numberOfVerticallySummedTracesYieldingThisTrace | refer to SEGY rev 1 documentation
Public property | originalFieldRecordNumber | refer to SEGY rev 1 documentation
Public property | overTravel | refer to SEGY rev 1 documentation
Public property | receiverGroupElevation | refer to SEGY rev 1 documentation
Public property | sampleIntervalUsec | refer to SEGY rev 1 documentation
Public property | scalarAppliedToShotPointNumber | refer to SEGY rev 1 documentation
Public property | scalarForAllElevationsAndDepths | refer to SEGY rev 1 documentation
Public property | scalarToBeAppliedToAllCoordinates | refer to SEGY rev 1 documentation
Public property | scalarUsedToScaleTraceHeaderMSecTimes | refer to SEGY rev 1 documentation
Public property | secondOfMinute | refer to SEGY rev 1 documentation
Public property | shotpointNumber | refer to SEGY rev 1 documentation
Public property | souceStaticCorrectionMsec | refer to SEGY rev 1 documentation
Public property | sourceCoordinateX | refer to SEGY rev 1 documentation
Public property | sourceCoordinateY | refer to SEGY rev 1 documentation
Public property | sourceDepthBelowSurface | refer to SEGY rev 1 documentation
Public property | sourceEnergyDirectionExponent | refer to SEGY rev 1 documentation
Public property | sourceEnergyDirectionMantissa | refer to SEGY rev 1 documentation
Public property | sourceMeasurementExponent | refer to SEGY rev 1 documentation
Public property | sourceMeasurementMantissa | refer to SEGY rev 1 documentation
Public property | sourceMeasurementUnit | refer to SEGY rev 1 documentation
Public property | sourceType | refer to SEGY rev 1 documentation
Public property | subweatheringVelocity | refer to SEGY rev 1 documentation
Public property | surfaceElevationAtSource | refer to SEGY rev 1 documentation
Public property | sweepFrequencyAtEnd | refer to SEGY rev 1 documentation
Public property | sweepFrequencyAtStart | refer to SEGY rev 1 documentation
Public property | sweepLengthInMsec | refer to SEGY rev 1 documentation
Public property | sweepTaperLenghtAtEndMsec | refer to SEGY rev 1 documentation
Public property | sweepTaperLengthAtStartMsec | refer to SEGY rev 1 documentation
Public property | sweepType | refer to SEGY rev 1 documentation
Public property | taperType | refer to SEGY rev 1 documentation
Public property | timeBasis | refer to SEGY rev 1 documentation
Public property | totalStaticMsec | refer to SEGY rev 1 documentation
Public property | TraceHeaderBuffer | SEGYTraceHeader storage block
Public property | traceIdentificationCode | refer to SEGY rev 1 documentation
Public property | traceNumberWithinEnsemble | refer to SEGY rev 1 documentation
Public property | traceNumberWithinOriginalFieldRecord | refer to SEGY rev 1 documentation
Public property | traceSequenceNumberWithinFile | refer to SEGY rev 1 documentation
Public property | traceSequenceNumberWithinLine | refer to SEGY rev 1 documentation
Public property | traceValueMeasurementUnit | refer to SEGY rev 1 documentation
Public property | traceWeightingFactor | refer to SEGY rev 1 documentation
Public property | transductionConstantExponent | refer to SEGY rev 1 documentation
Public property | transductionConstantMantissa | refer to SEGY rev 1 documentation
Public property | transductionUnits | refer to SEGY rev 1 documentation
Public property | upholeTimeAtGroupMsec | refer to SEGY rev 1 documentation
Public property | upholeTimeAtSourceMsec | refer to SEGY rev 1 documentation
Public property | waterDepthAtGroup | refer to SEGY rev 1 documentation
Public property | waterDepthAtSource | refer to SEGY rev 1 documentation
Public property | weatheringVelocity | refer to SEGY rev 1 documentation
Public property | xCoordinateOfEnsemble | refer to SEGY rev 1 documentation
Public property | yCoordinateOfEnsemble | refer to SEGY rev 1 documentation
Public property | yearDataRecorded | refer to SEGY rev 1 documentation
Top
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.aliasFilterSlopeDBOctave Property

SEGYTraceHeaderaliasFilterSlopeDBOctave Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short aliasFilterSlopeDBOctave { get; set; }
Public Property aliasFilterSlopeDBOctave As Short
    Get
    Set
public:
property short aliasFilterSlopeDBOctave {
    short get ();
    void set (short value);
}
member aliasFilterSlopeDBOctave : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.aliasFrequencyHz Property

SEGYTraceHeaderaliasFrequencyHz Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort aliasFrequencyHz { get; set; }
Public Property aliasFrequencyHz As UShort
    Get
    Set
public:
property unsigned short aliasFrequencyHz {
    unsigned short get ();
    void set (unsigned short value);
}
member aliasFrequencyHz : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.bigEndian Property

SEGYTraceHeaderbigEndian Property
true if big endian

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool bigEndian { get; set; }
Public Property bigEndian As Boolean
    Get
    Set
public:
property bool bigEndian {
    bool get ();
    void set (bool value);
}
member bigEndian : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.coordinateUnits Property

SEGYTraceHeadercoordinateUnits Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort coordinateUnits { get; set; }
Public Property coordinateUnits As UShort
    Get
    Set
public:
property unsigned short coordinateUnits {
    unsigned short get ();
    void set (unsigned short value);
}
member coordinateUnits : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.correlated Property

SEGYTraceHeadercorrelated Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort correlated { get; set; }
Public Property correlated As UShort
    Get
    Set
public:
property unsigned short correlated {
    unsigned short get ();
    void set (unsigned short value);
}
member correlated : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.crossLineNumber3D Property

SEGYTraceHeadercrossLineNumber3D Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint crossLineNumber3D { get; set; }
Public Property crossLineNumber3D As UInteger
    Get
    Set
public:
property unsigned int crossLineNumber3D {
    unsigned int get ();
    void set (unsigned int value);
}
member crossLineNumber3D : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.dataUse Property

SEGYTraceHeaderdataUse Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort dataUse { get; set; }
Public Property dataUse As UShort
    Get
    Set
public:
property unsigned short dataUse {
    unsigned short get ();
    void set (unsigned short value);
}
member dataUse : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.datumElevationAtReceiverGroup Property

SEGYTraceHeaderdatumElevationAtReceiverGroup Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int datumElevationAtReceiverGroup { get; set; }
Public Property datumElevationAtReceiverGroup As Integer
    Get
    Set
public:
property int datumElevationAtReceiverGroup {
    int get ();
    void set (int value);
}
member datumElevationAtReceiverGroup : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.datumElevationAtSource Property

SEGYTraceHeaderdatumElevationAtSource Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int datumElevationAtSource { get; set; }
Public Property datumElevationAtSource As Integer
    Get
    Set
public:
property int datumElevationAtSource {
    int get ();
    void set (int value);
}
member datumElevationAtSource : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.dayOfYear Property

SEGYTraceHeaderdayOfYear Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort dayOfYear { get; set; }
Public Property dayOfYear As UShort
    Get
    Set
public:
property unsigned short dayOfYear {
    unsigned short get ();
    void set (unsigned short value);
}
member dayOfYear : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.delayRecordingTimeMsec Property

SEGYTraceHeaderdelayRecordingTimeMsec Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short delayRecordingTimeMsec { get; set; }
Public Property delayRecordingTimeMsec As Short
    Get
    Set
public:
property short delayRecordingTimeMsec {
    short get ();
    void set (short value);
}
member delayRecordingTimeMsec : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.deviceTraceIdentifier Property

SEGYTraceHeaderdeviceTraceIdentifier Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short deviceTraceIdentifier { get; set; }
Public Property deviceTraceIdentifier As Short
    Get
    Set
public:
property short deviceTraceIdentifier {
    short get ();
    void set (short value);
}
member deviceTraceIdentifier : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.distanceFromCenterOfSourcePointToCenterOfGroup Property

SEGYTraceHeaderdistanceFromCenterOfSourcePointToCenterOfGroup Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int distanceFromCenterOfSourcePointToCenterOfGroup { get; set; }
Public Property distanceFromCenterOfSourcePointToCenterOfGroup As Integer
    Get
    Set
public:
property int distanceFromCenterOfSourcePointToCenterOfGroup {
    int get ();
    void set (int value);
}
member distanceFromCenterOfSourcePointToCenterOfGroup : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.energySourcePointNumber Property

SEGYTraceHeaderenergySourcePointNumber Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint energySourcePointNumber { get; set; }
Public Property energySourcePointNumber As UInteger
    Get
    Set
public:
property unsigned int energySourcePointNumber {
    unsigned int get ();
    void set (unsigned int value);
}
member energySourcePointNumber : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.ensembleNumber Property

SEGYTraceHeaderensembleNumber Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint ensembleNumber { get; set; }
Public Property ensembleNumber As UInteger
    Get
    Set
public:
property unsigned int ensembleNumber {
    unsigned int get ();
    void set (unsigned int value);
}
member ensembleNumber : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.gainTypeOfFieldInstruments Property

SEGYTraceHeadergainTypeOfFieldInstruments Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort gainTypeOfFieldInstruments { get; set; }
Public Property gainTypeOfFieldInstruments As UShort
    Get
    Set
public:
property unsigned short gainTypeOfFieldInstruments {
    unsigned short get ();
    void set (unsigned short value);
}
member gainTypeOfFieldInstruments : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.gapSize Property

SEGYTraceHeadergapSize Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort gapSize { get; set; }
Public Property gapSize As UShort
    Get
    Set
public:
property unsigned short gapSize {
    unsigned short get ();
    void set (unsigned short value);
}
member gapSize : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.geophoneGroupNumberofLastTraceWithinOriginalFieldRecord Property

SEGYTraceHeadergeophoneGroupNumberofLastTraceWithinOriginalFieldRecord Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort geophoneGroupNumberofLastTraceWithinOriginalFieldRecord { get; set; }
Public Property geophoneGroupNumberofLastTraceWithinOriginalFieldRecord As UShort
    Get
    Set
public:
property unsigned short geophoneGroupNumberofLastTraceWithinOriginalFieldRecord {
    unsigned short get ();
    void set (unsigned short value);
}
member geophoneGroupNumberofLastTraceWithinOriginalFieldRecord : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.geophoneGroupNumberOfRollSwitchPositionOne Property

SEGYTraceHeadergeophoneGroupNumberOfRollSwitchPositionOne Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort geophoneGroupNumberOfRollSwitchPositionOne { get; set; }
Public Property geophoneGroupNumberOfRollSwitchPositionOne As UShort
    Get
    Set
public:
property unsigned short geophoneGroupNumberOfRollSwitchPositionOne {
    unsigned short get ();
    void set (unsigned short value);
}
member geophoneGroupNumberOfRollSwitchPositionOne : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.geophoneGroupNumberofTraceNumberOneWithinOriginalFieldRecord Property

SEGYTraceHeadergeophoneGroupNumberofTraceNumberOneWithinOriginalFieldRecord Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort geophoneGroupNumberofTraceNumberOneWithinOriginalFieldRecord { get; set; }
Public Property geophoneGroupNumberofTraceNumberOneWithinOriginalFieldRecord As UShort
    Get
    Set
public:
property unsigned short geophoneGroupNumberofTraceNumberOneWithinOriginalFieldRecord {
    unsigned short get ();
    void set (unsigned short value);
}
member geophoneGroupNumberofTraceNumberOneWithinOriginalFieldRecord : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.groupCoordinateX Property

SEGYTraceHeadergroupCoordinateX Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int groupCoordinateX { get; set; }
Public Property groupCoordinateX As Integer
    Get
    Set
public:
property int groupCoordinateX {
    int get ();
    void set (int value);
}
member groupCoordinateX : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.groupCoordinateY Property

SEGYTraceHeadergroupCoordinateY Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int groupCoordinateY { get; set; }
Public Property groupCoordinateY As Integer
    Get
    Set
public:
property int groupCoordinateY {
    int get ();
    void set (int value);
}
member groupCoordinateY : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.groupStaticCorrectionMsec Property

SEGYTraceHeadergroupStaticCorrectionMsec Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort groupStaticCorrectionMsec { get; set; }
Public Property groupStaticCorrectionMsec As UShort
    Get
    Set
public:
property unsigned short groupStaticCorrectionMsec {
    unsigned short get ();
    void set (unsigned short value);
}
member groupStaticCorrectionMsec : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.highCutFrequencyHz Property

SEGYTraceHeaderhighCutFrequencyHz Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort highCutFrequencyHz { get; set; }
Public Property highCutFrequencyHz As UShort
    Get
    Set
public:
property unsigned short highCutFrequencyHz {
    unsigned short get ();
    void set (unsigned short value);
}
member highCutFrequencyHz : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.highCutSlopeDBOctave Property

SEGYTraceHeaderhighCutSlopeDBOctave Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short highCutSlopeDBOctave { get; set; }
Public Property highCutSlopeDBOctave As Short
    Get
    Set
public:
property short highCutSlopeDBOctave {
    short get ();
    void set (short value);
}
member highCutSlopeDBOctave : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.hourOfDay Property

SEGYTraceHeaderhourOfDay Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort hourOfDay { get; set; }
Public Property hourOfDay As UShort
    Get
    Set
public:
property unsigned short hourOfDay {
    unsigned short get ();
    void set (unsigned short value);
}
member hourOfDay : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.inLineNumber3D Property

SEGYTraceHeaderinLineNumber3D Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint inLineNumber3D { get; set; }
Public Property inLineNumber3D As UInteger
    Get
    Set
public:
property unsigned int inLineNumber3D {
    unsigned int get ();
    void set (unsigned int value);
}
member inLineNumber3D : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.instrumentEarlyOrIntialGainDB Property

SEGYTraceHeaderinstrumentEarlyOrIntialGainDB Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short instrumentEarlyOrIntialGainDB { get; set; }
Public Property instrumentEarlyOrIntialGainDB As Short
    Get
    Set
public:
property short instrumentEarlyOrIntialGainDB {
    short get ();
    void set (short value);
}
member instrumentEarlyOrIntialGainDB : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.instrumentGainConstantDB Property

SEGYTraceHeaderinstrumentGainConstantDB Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short instrumentGainConstantDB { get; set; }
Public Property instrumentGainConstantDB As Short
    Get
    Set
public:
property short instrumentGainConstantDB {
    short get ();
    void set (short value);
}
member instrumentGainConstantDB : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.lagTimeAMsec Property

SEGYTraceHeaderlagTimeAMsec Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short lagTimeAMsec { get; set; }
Public Property lagTimeAMsec As Short
    Get
    Set
public:
property short lagTimeAMsec {
    short get ();
    void set (short value);
}
member lagTimeAMsec : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.lagTimeBMsec Property

SEGYTraceHeaderlagTimeBMsec Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short lagTimeBMsec { get; set; }
Public Property lagTimeBMsec As Short
    Get
    Set
public:
property short lagTimeBMsec {
    short get ();
    void set (short value);
}
member lagTimeBMsec : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.lowCutFrequencyHz Property

SEGYTraceHeaderlowCutFrequencyHz Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort lowCutFrequencyHz { get; set; }
Public Property lowCutFrequencyHz As UShort
    Get
    Set
public:
property unsigned short lowCutFrequencyHz {
    unsigned short get ();
    void set (unsigned short value);
}
member lowCutFrequencyHz : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.lowCutSlopeDBOctave Property

SEGYTraceHeaderlowCutSlopeDBOctave Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short lowCutSlopeDBOctave { get; set; }
Public Property lowCutSlopeDBOctave As Short
    Get
    Set
public:
property short lowCutSlopeDBOctave {
    short get ();
    void set (short value);
}
member lowCutSlopeDBOctave : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.minuteOfHour Property

SEGYTraceHeaderminuteOfHour Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort minuteOfHour { get; set; }
Public Property minuteOfHour As UShort
    Get
    Set
public:
property unsigned short minuteOfHour {
    unsigned short get ();
    void set (unsigned short value);
}
member minuteOfHour : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.muteTimeEndTimeMsec Property

SEGYTraceHeadermuteTimeEndTimeMsec Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort muteTimeEndTimeMsec { get; set; }
Public Property muteTimeEndTimeMsec As UShort
    Get
    Set
public:
property unsigned short muteTimeEndTimeMsec {
    unsigned short get ();
    void set (unsigned short value);
}
member muteTimeEndTimeMsec : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.muteTimeStartTimeMsec Property

SEGYTraceHeadermuteTimeStartTimeMsec Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort muteTimeStartTimeMsec { get; set; }
Public Property muteTimeStartTimeMsec As UShort
    Get
    Set
public:
property unsigned short muteTimeStartTimeMsec {
    unsigned short get ();
    void set (unsigned short value);
}
member muteTimeStartTimeMsec : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.notchFilterSlopeDBOctave Property

SEGYTraceHeadernotchFilterSlopeDBOctave Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short notchFilterSlopeDBOctave { get; set; }
Public Property notchFilterSlopeDBOctave As Short
    Get
    Set
public:
property short notchFilterSlopeDBOctave {
    short get ();
    void set (short value);
}
member notchFilterSlopeDBOctave : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.notchFrequencyHz Property

SEGYTraceHeadernotchFrequencyHz Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort notchFrequencyHz { get; set; }
Public Property notchFrequencyHz As UShort
    Get
    Set
public:
property unsigned short notchFrequencyHz {
    unsigned short get ();
    void set (unsigned short value);
}
member notchFrequencyHz : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.numberOfHorizonatallySummedTracesYieldingThisTrace Property

SEGYTraceHeadernumberOfHorizonatallySummedTracesYieldingThisTrace Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort numberOfHorizonatallySummedTracesYieldingThisTrace { get; set; }
Public Property numberOfHorizonatallySummedTracesYieldingThisTrace As UShort
    Get
    Set
public:
property unsigned short numberOfHorizonatallySummedTracesYieldingThisTrace {
    unsigned short get ();
    void set (unsigned short value);
}
member numberOfHorizonatallySummedTracesYieldingThisTrace : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.numberOfSamplesInTrace Property

SEGYTraceHeadernumberOfSamplesInTrace Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort numberOfSamplesInTrace { get; set; }
Public Property numberOfSamplesInTrace As UShort
    Get
    Set
public:
property unsigned short numberOfSamplesInTrace {
    unsigned short get ();
    void set (unsigned short value);
}
member numberOfSamplesInTrace : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.numberOfVerticallySummedTracesYieldingThisTrace Property

SEGYTraceHeadernumberOfVerticallySummedTracesYieldingThisTrace Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort numberOfVerticallySummedTracesYieldingThisTrace { get; set; }
Public Property numberOfVerticallySummedTracesYieldingThisTrace As UShort
    Get
    Set
public:
property unsigned short numberOfVerticallySummedTracesYieldingThisTrace {
    unsigned short get ();
    void set (unsigned short value);
}
member numberOfVerticallySummedTracesYieldingThisTrace : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.originalFieldRecordNumber Property

SEGYTraceHeaderoriginalFieldRecordNumber Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint originalFieldRecordNumber { get; set; }
Public Property originalFieldRecordNumber As UInteger
    Get
    Set
public:
property unsigned int originalFieldRecordNumber {
    unsigned int get ();
    void set (unsigned int value);
}
member originalFieldRecordNumber : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.overTravel Property

SEGYTraceHeaderoverTravel Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort overTravel { get; set; }
Public Property overTravel As UShort
    Get
    Set
public:
property unsigned short overTravel {
    unsigned short get ();
    void set (unsigned short value);
}
member overTravel : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.receiverGroupElevation Property

SEGYTraceHeaderreceiverGroupElevation Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int receiverGroupElevation { get; set; }
Public Property receiverGroupElevation As Integer
    Get
    Set
public:
property int receiverGroupElevation {
    int get ();
    void set (int value);
}
member receiverGroupElevation : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.sampleIntervalUsec Property

SEGYTraceHeadersampleIntervalUsec Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort sampleIntervalUsec { get; set; }
Public Property sampleIntervalUsec As UShort
    Get
    Set
public:
property unsigned short sampleIntervalUsec {
    unsigned short get ();
    void set (unsigned short value);
}
member sampleIntervalUsec : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.scalarAppliedToShotPointNumber Property

SEGYTraceHeaderscalarAppliedToShotPointNumber Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short scalarAppliedToShotPointNumber { get; set; }
Public Property scalarAppliedToShotPointNumber As Short
    Get
    Set
public:
property short scalarAppliedToShotPointNumber {
    short get ();
    void set (short value);
}
member scalarAppliedToShotPointNumber : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.scalarForAllElevationsAndDepths Property

SEGYTraceHeaderscalarForAllElevationsAndDepths Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short scalarForAllElevationsAndDepths { get; set; }
Public Property scalarForAllElevationsAndDepths As Short
    Get
    Set
public:
property short scalarForAllElevationsAndDepths {
    short get ();
    void set (short value);
}
member scalarForAllElevationsAndDepths : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.scalarToBeAppliedToAllCoordinates Property

SEGYTraceHeaderscalarToBeAppliedToAllCoordinates Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short scalarToBeAppliedToAllCoordinates { get; set; }
Public Property scalarToBeAppliedToAllCoordinates As Short
    Get
    Set
public:
property short scalarToBeAppliedToAllCoordinates {
    short get ();
    void set (short value);
}
member scalarToBeAppliedToAllCoordinates : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.scalarUsedToScaleTraceHeaderMSecTimes Property

SEGYTraceHeaderscalarUsedToScaleTraceHeaderMSecTimes Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short scalarUsedToScaleTraceHeaderMSecTimes { get; set; }
Public Property scalarUsedToScaleTraceHeaderMSecTimes As Short
    Get
    Set
public:
property short scalarUsedToScaleTraceHeaderMSecTimes {
    short get ();
    void set (short value);
}
member scalarUsedToScaleTraceHeaderMSecTimes : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.secondOfMinute Property

SEGYTraceHeadersecondOfMinute Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort secondOfMinute { get; set; }
Public Property secondOfMinute As UShort
    Get
    Set
public:
property unsigned short secondOfMinute {
    unsigned short get ();
    void set (unsigned short value);
}
member secondOfMinute : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.shotpointNumber Property

SEGYTraceHeadershotpointNumber Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint shotpointNumber { get; set; }
Public Property shotpointNumber As UInteger
    Get
    Set
public:
property unsigned int shotpointNumber {
    unsigned int get ();
    void set (unsigned int value);
}
member shotpointNumber : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.souceStaticCorrectionMsec Property

SEGYTraceHeadersouceStaticCorrectionMsec Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort souceStaticCorrectionMsec { get; set; }
Public Property souceStaticCorrectionMsec As UShort
    Get
    Set
public:
property unsigned short souceStaticCorrectionMsec {
    unsigned short get ();
    void set (unsigned short value);
}
member souceStaticCorrectionMsec : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.sourceCoordinateX Property

SEGYTraceHeadersourceCoordinateX Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int sourceCoordinateX { get; set; }
Public Property sourceCoordinateX As Integer
    Get
    Set
public:
property int sourceCoordinateX {
    int get ();
    void set (int value);
}
member sourceCoordinateX : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.sourceCoordinateY Property

SEGYTraceHeadersourceCoordinateY Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int sourceCoordinateY { get; set; }
Public Property sourceCoordinateY As Integer
    Get
    Set
public:
property int sourceCoordinateY {
    int get ();
    void set (int value);
}
member sourceCoordinateY : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.sourceDepthBelowSurface Property

SEGYTraceHeadersourceDepthBelowSurface Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int sourceDepthBelowSurface { get; set; }
Public Property sourceDepthBelowSurface As Integer
    Get
    Set
public:
property int sourceDepthBelowSurface {
    int get ();
    void set (int value);
}
member sourceDepthBelowSurface : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.sourceEnergyDirectionExponent Property

SEGYTraceHeadersourceEnergyDirectionExponent Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short sourceEnergyDirectionExponent { get; set; }
Public Property sourceEnergyDirectionExponent As Short
    Get
    Set
public:
property short sourceEnergyDirectionExponent {
    short get ();
    void set (short value);
}
member sourceEnergyDirectionExponent : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.sourceEnergyDirectionMantissa Property

SEGYTraceHeadersourceEnergyDirectionMantissa Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int sourceEnergyDirectionMantissa { get; set; }
Public Property sourceEnergyDirectionMantissa As Integer
    Get
    Set
public:
property int sourceEnergyDirectionMantissa {
    int get ();
    void set (int value);
}
member sourceEnergyDirectionMantissa : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.sourceMeasurementExponent Property

SEGYTraceHeadersourceMeasurementExponent Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short sourceMeasurementExponent { get; set; }
Public Property sourceMeasurementExponent As Short
    Get
    Set
public:
property short sourceMeasurementExponent {
    short get ();
    void set (short value);
}
member sourceMeasurementExponent : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.sourceMeasurementMantissa Property

SEGYTraceHeadersourceMeasurementMantissa Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int sourceMeasurementMantissa { get; set; }
Public Property sourceMeasurementMantissa As Integer
    Get
    Set
public:
property int sourceMeasurementMantissa {
    int get ();
    void set (int value);
}
member sourceMeasurementMantissa : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.sourceMeasurementUnit Property

SEGYTraceHeadersourceMeasurementUnit Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short sourceMeasurementUnit { get; set; }
Public Property sourceMeasurementUnit As Short
    Get
    Set
public:
property short sourceMeasurementUnit {
    short get ();
    void set (short value);
}
member sourceMeasurementUnit : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.sourceType Property

SEGYTraceHeadersourceType Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short sourceType { get; set; }
Public Property sourceType As Short
    Get
    Set
public:
property short sourceType {
    short get ();
    void set (short value);
}
member sourceType : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.subweatheringVelocity Property

SEGYTraceHeadersubweatheringVelocity Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort subweatheringVelocity { get; set; }
Public Property subweatheringVelocity As UShort
    Get
    Set
public:
property unsigned short subweatheringVelocity {
    unsigned short get ();
    void set (unsigned short value);
}
member subweatheringVelocity : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.surfaceElevationAtSource Property

SEGYTraceHeadersurfaceElevationAtSource Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int surfaceElevationAtSource { get; set; }
Public Property surfaceElevationAtSource As Integer
    Get
    Set
public:
property int surfaceElevationAtSource {
    int get ();
    void set (int value);
}
member surfaceElevationAtSource : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.sweepFrequencyAtEnd Property

SEGYTraceHeadersweepFrequencyAtEnd Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort sweepFrequencyAtEnd { get; set; }
Public Property sweepFrequencyAtEnd As UShort
    Get
    Set
public:
property unsigned short sweepFrequencyAtEnd {
    unsigned short get ();
    void set (unsigned short value);
}
member sweepFrequencyAtEnd : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.sweepFrequencyAtStart Property

SEGYTraceHeadersweepFrequencyAtStart Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort sweepFrequencyAtStart { get; set; }
Public Property sweepFrequencyAtStart As UShort
    Get
    Set
public:
property unsigned short sweepFrequencyAtStart {
    unsigned short get ();
    void set (unsigned short value);
}
member sweepFrequencyAtStart : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.sweepLengthInMsec Property

SEGYTraceHeadersweepLengthInMsec Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort sweepLengthInMsec { get; set; }
Public Property sweepLengthInMsec As UShort
    Get
    Set
public:
property unsigned short sweepLengthInMsec {
    unsigned short get ();
    void set (unsigned short value);
}
member sweepLengthInMsec : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.sweepTaperLenghtAtEndMsec Property

SEGYTraceHeadersweepTaperLenghtAtEndMsec Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort sweepTaperLenghtAtEndMsec { get; set; }
Public Property sweepTaperLenghtAtEndMsec As UShort
    Get
    Set
public:
property unsigned short sweepTaperLenghtAtEndMsec {
    unsigned short get ();
    void set (unsigned short value);
}
member sweepTaperLenghtAtEndMsec : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.sweepTaperLengthAtStartMsec Property

SEGYTraceHeadersweepTaperLengthAtStartMsec Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort sweepTaperLengthAtStartMsec { get; set; }
Public Property sweepTaperLengthAtStartMsec As UShort
    Get
    Set
public:
property unsigned short sweepTaperLengthAtStartMsec {
    unsigned short get ();
    void set (unsigned short value);
}
member sweepTaperLengthAtStartMsec : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.sweepType Property

SEGYTraceHeadersweepType Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort sweepType { get; set; }
Public Property sweepType As UShort
    Get
    Set
public:
property unsigned short sweepType {
    unsigned short get ();
    void set (unsigned short value);
}
member sweepType : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.taperType Property

SEGYTraceHeadertaperType Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort taperType { get; set; }
Public Property taperType As UShort
    Get
    Set
public:
property unsigned short taperType {
    unsigned short get ();
    void set (unsigned short value);
}
member taperType : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.timeBasis Property

SEGYTraceHeadertimeBasis Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort timeBasis { get; set; }
Public Property timeBasis As UShort
    Get
    Set
public:
property unsigned short timeBasis {
    unsigned short get ();
    void set (unsigned short value);
}
member timeBasis : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.totalStaticMsec Property

SEGYTraceHeadertotalStaticMsec Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short totalStaticMsec { get; set; }
Public Property totalStaticMsec As Short
    Get
    Set
public:
property short totalStaticMsec {
    short get ();
    void set (short value);
}
member totalStaticMsec : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.TraceHeaderBuffer Property

SEGYTraceHeaderTraceHeaderBuffer Property
SEGYTraceHeader storage block

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] TraceHeaderBuffer { get; set; }
Public Property TraceHeaderBuffer As Byte()
    Get
    Set
public:
property array<unsigned char>^ TraceHeaderBuffer {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member TraceHeaderBuffer : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.traceIdentificationCode Property

SEGYTraceHeadertraceIdentificationCode Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short traceIdentificationCode { get; set; }
Public Property traceIdentificationCode As Short
    Get
    Set
public:
property short traceIdentificationCode {
    short get ();
    void set (short value);
}
member traceIdentificationCode : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.traceNumberWithinEnsemble Property

SEGYTraceHeadertraceNumberWithinEnsemble Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint traceNumberWithinEnsemble { get; set; }
Public Property traceNumberWithinEnsemble As UInteger
    Get
    Set
public:
property unsigned int traceNumberWithinEnsemble {
    unsigned int get ();
    void set (unsigned int value);
}
member traceNumberWithinEnsemble : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.traceNumberWithinOriginalFieldRecord Property

SEGYTraceHeadertraceNumberWithinOriginalFieldRecord Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint traceNumberWithinOriginalFieldRecord { get; set; }
Public Property traceNumberWithinOriginalFieldRecord As UInteger
    Get
    Set
public:
property unsigned int traceNumberWithinOriginalFieldRecord {
    unsigned int get ();
    void set (unsigned int value);
}
member traceNumberWithinOriginalFieldRecord : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.traceSequenceNumberWithinFile Property

SEGYTraceHeadertraceSequenceNumberWithinFile Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint traceSequenceNumberWithinFile { get; set; }
Public Property traceSequenceNumberWithinFile As UInteger
    Get
    Set
public:
property unsigned int traceSequenceNumberWithinFile {
    unsigned int get ();
    void set (unsigned int value);
}
member traceSequenceNumberWithinFile : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.traceSequenceNumberWithinLine Property

SEGYTraceHeadertraceSequenceNumberWithinLine Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint traceSequenceNumberWithinLine { get; set; }
Public Property traceSequenceNumberWithinLine As UInteger
    Get
    Set
public:
property unsigned int traceSequenceNumberWithinLine {
    unsigned int get ();
    void set (unsigned int value);
}
member traceSequenceNumberWithinLine : uint32 with get, set

Property Value

Type: UInt32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.traceValueMeasurementUnit Property

SEGYTraceHeadertraceValueMeasurementUnit Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short traceValueMeasurementUnit { get; set; }
Public Property traceValueMeasurementUnit As Short
    Get
    Set
public:
property short traceValueMeasurementUnit {
    short get ();
    void set (short value);
}
member traceValueMeasurementUnit : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.traceWeightingFactor Property

SEGYTraceHeadertraceWeightingFactor Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort traceWeightingFactor { get; set; }
Public Property traceWeightingFactor As UShort
    Get
    Set
public:
property unsigned short traceWeightingFactor {
    unsigned short get ();
    void set (unsigned short value);
}
member traceWeightingFactor : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.transductionConstantExponent Property

SEGYTraceHeadertransductionConstantExponent Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short transductionConstantExponent { get; set; }
Public Property transductionConstantExponent As Short
    Get
    Set
public:
property short transductionConstantExponent {
    short get ();
    void set (short value);
}
member transductionConstantExponent : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.transductionConstantMantissa Property

SEGYTraceHeadertransductionConstantMantissa Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int transductionConstantMantissa { get; set; }
Public Property transductionConstantMantissa As Integer
    Get
    Set
public:
property int transductionConstantMantissa {
    int get ();
    void set (int value);
}
member transductionConstantMantissa : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.transductionUnits Property

SEGYTraceHeadertransductionUnits Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short transductionUnits { get; set; }
Public Property transductionUnits As Short
    Get
    Set
public:
property short transductionUnits {
    short get ();
    void set (short value);
}
member transductionUnits : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.upholeTimeAtGroupMsec Property

SEGYTraceHeaderupholeTimeAtGroupMsec Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort upholeTimeAtGroupMsec { get; set; }
Public Property upholeTimeAtGroupMsec As UShort
    Get
    Set
public:
property unsigned short upholeTimeAtGroupMsec {
    unsigned short get ();
    void set (unsigned short value);
}
member upholeTimeAtGroupMsec : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.upholeTimeAtSourceMsec Property

SEGYTraceHeaderupholeTimeAtSourceMsec Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort upholeTimeAtSourceMsec { get; set; }
Public Property upholeTimeAtSourceMsec As UShort
    Get
    Set
public:
property unsigned short upholeTimeAtSourceMsec {
    unsigned short get ();
    void set (unsigned short value);
}
member upholeTimeAtSourceMsec : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.waterDepthAtGroup Property

SEGYTraceHeaderwaterDepthAtGroup Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int waterDepthAtGroup { get; set; }
Public Property waterDepthAtGroup As Integer
    Get
    Set
public:
property int waterDepthAtGroup {
    int get ();
    void set (int value);
}
member waterDepthAtGroup : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.waterDepthAtSource Property

SEGYTraceHeaderwaterDepthAtSource Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int waterDepthAtSource { get; set; }
Public Property waterDepthAtSource As Integer
    Get
    Set
public:
property int waterDepthAtSource {
    int get ();
    void set (int value);
}
member waterDepthAtSource : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.weatheringVelocity Property

SEGYTraceHeaderweatheringVelocity Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort weatheringVelocity { get; set; }
Public Property weatheringVelocity As UShort
    Get
    Set
public:
property unsigned short weatheringVelocity {
    unsigned short get ();
    void set (unsigned short value);
}
member weatheringVelocity : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.xCoordinateOfEnsemble Property

SEGYTraceHeaderxCoordinateOfEnsemble Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int xCoordinateOfEnsemble { get; set; }
Public Property xCoordinateOfEnsemble As Integer
    Get
    Set
public:
property int xCoordinateOfEnsemble {
    int get ();
    void set (int value);
}
member xCoordinateOfEnsemble : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.yCoordinateOfEnsemble Property

SEGYTraceHeaderyCoordinateOfEnsemble Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int yCoordinateOfEnsemble { get; set; }
Public Property yCoordinateOfEnsemble As Integer
    Get
    Set
public:
property int yCoordinateOfEnsemble {
    int get ();
    void set (int value);
}
member yCoordinateOfEnsemble : int with get, set

Property Value

Type: Int32
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.yearDataRecorded Property

SEGYTraceHeaderyearDataRecorded Property
refer to SEGY rev 1 documentation

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ushort yearDataRecorded { get; set; }
Public Property yearDataRecorded As UShort
    Get
    Set
public:
property unsigned short yearDataRecorded {
    unsigned short get ();
    void set (unsigned short value);
}
member yearDataRecorded : uint16 with get, set

Property Value

Type: UInt16
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader Methods

SEGYTraceHeader Methods

The SEGYTraceHeader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | initialize object
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SEGYTraceHeader Class


SEGYTraceHeader.Initialize Method

SEGYTraceHeaderInitialize Method
initialize object

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Initialize(
    bool bigEndian
)
Public Sub Initialize (
    bigEndian As Boolean
)
public:
void Initialize(
    bool bigEndian
)
member Initialize :
        bigEndian : bool -> unit

Parameters

bigEndian
Type: SystemBoolean

[Missing <param name="bigEndian"/> documentation for "M:SEGYlib.SEGYTraceHeader.Initialize(System.Boolean)"]

See Also

Reference

SEGYTraceHeader Class


SEGYUtilities Class

SEGYUtilities Class
SEGYUtilities for use in reading and writing SEGY files
Inheritance Hierarchy
SystemObject
SEGYlibSEGYUtilities

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SEGYUtilities
Public Class SEGYUtilities
public ref class SEGYUtilities
type SEGYUtilities =  class end

The SEGYUtilities type exposes the following members.

Constructors
 | Name | Description
Public method | SEGYUtilities | Initializes a new instance of the SEGYUtilities class
Top
Methods
 | Name | Description
 | Bytes2Int | convert bytes to long int
 | ConvertAsciiToEbcdic | convert an ASCII byte array to an EBCDIC byte array
 | ConvertEbcdicToAscii | convert an EBCDIC byte array to an ASCII byte array
 | convertPositionToint | convert a position to a SEGY trace header integer
 | convertToPosition | convert a SEGY trace header positional value to position
 | decimalDegreesToDMS | convert decimal degrees to degrees-minutes-seconds
 | degreesToSecondsOfArc | convert decimal degrees to seconds of arc
 | dmsToDecimalDegrees | convert degrees-minutes-seconds to decimal degrees
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Int2Bytes | convert a long int to bytes
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | secondsOfArctoDegrees | convert seconds of arc to decimal degrees
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SEGYlib Namespace
Send comments on this topic to bob.courtney@canada.ca


SEGYUtilities Constructor

SEGYUtilities Constructor
Initializes a new instance of the SEGYUtilities class

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SEGYUtilities()
Public Sub New
public:
SEGYUtilities()
new : unit -> SEGYUtilities
See Also

Reference

SEGYUtilities Class


SEGYUtilities Methods

SEGYUtilities Methods

The SEGYUtilities type exposes the following members.

Methods
 | Name | Description
 | Bytes2Int | convert bytes to long int
 | ConvertAsciiToEbcdic | convert an ASCII byte array to an EBCDIC byte array
 | ConvertEbcdicToAscii | convert an EBCDIC byte array to an ASCII byte array
 | convertPositionToint | convert a position to a SEGY trace header integer
 | convertToPosition | convert a SEGY trace header positional value to position
 | decimalDegreesToDMS | convert decimal degrees to degrees-minutes-seconds
 | degreesToSecondsOfArc | convert decimal degrees to seconds of arc
 | dmsToDecimalDegrees | convert degrees-minutes-seconds to decimal degrees
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Int2Bytes | convert a long int to bytes
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | secondsOfArctoDegrees | convert seconds of arc to decimal degrees
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SEGYUtilities Class


SEGYUtilities.Bytes2Int Method

SEGYUtilitiesBytes2Int Method
convert bytes to long int

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static long Bytes2Int(
    byte[] byteArray,
    int startPosition,
    int length,
    bool signed,
    bool swap
)
Public Shared Function Bytes2Int (
    byteArray As Byte(),
    startPosition As Integer,
    length As Integer,
    signed As Boolean,
    swap As Boolean
) As Long
public:
static long long Bytes2Int(
    array<unsigned char>^ byteArray,
    int startPosition,
    int length,
    bool signed,
    bool swap
)
static member Bytes2Int :
        byteArray : byte[] *
        startPosition : int *
        length : int *
        signed : bool *
        swap : bool -> int64

Parameters

byteArray
Type: SystemByte
input byte array
startPosition
Type: SystemInt32
starting position
length
Type: SystemInt32
length of byte array
signed
Type: SystemBoolean
is the value signed
swap
Type: SystemBoolean
swap the bytes first

Return Value

Type: Int64
long integer converted from byte array
See Also

Reference

SEGYUtilities Class


SEGYUtilities.ConvertAsciiToEbcdic Method

SEGYUtilitiesConvertAsciiToEbcdic Method
convert an ASCII byte array to an EBCDIC byte array

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static byte[] ConvertAsciiToEbcdic(
    byte[] asciiData
)
Public Shared Function ConvertAsciiToEbcdic (
    asciiData As Byte()
) As Byte()
public:
static array<unsigned char>^ ConvertAsciiToEbcdic(
    array<unsigned char>^ asciiData
)
static member ConvertAsciiToEbcdic :
        asciiData : byte[] -> byte[]

Parameters

asciiData
Type: SystemByte
input ASCII-formatted byte array

Return Value

Type: Byte
byte array containing EBCDIC formatted text data
See Also

Reference

SEGYUtilities Class


SEGYUtilities.ConvertEbcdicToAscii Method

SEGYUtilitiesConvertEbcdicToAscii Method
convert an EBCDIC byte array to an ASCII byte array

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static byte[] ConvertEbcdicToAscii(
    byte[] ebcdicData
)
Public Shared Function ConvertEbcdicToAscii (
    ebcdicData As Byte()
) As Byte()
public:
static array<unsigned char>^ ConvertEbcdicToAscii(
    array<unsigned char>^ ebcdicData
)
static member ConvertEbcdicToAscii :
        ebcdicData : byte[] -> byte[]

Parameters

ebcdicData
Type: SystemByte
input EBCDIC array

Return Value

Type: Byte
byte array containing ASCII formatted text data
See Also

Reference

SEGYUtilities Class


SEGYUtilities.convertPositionToint Method

SEGYUtilitiesconvertPositionToint Method
convert a position to a SEGY trace header integer

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int convertPositionToint(
    double d,
    ushort coordinateSystem,
    double scalarToBeAppliedToAllCoordinates
)
Public Shared Function convertPositionToint (
    d As Double,
    coordinateSystem As UShort,
    scalarToBeAppliedToAllCoordinates As Double
) As Integer
public:
static int convertPositionToint(
    double d,
    unsigned short coordinateSystem,
    double scalarToBeAppliedToAllCoordinates
)
static member convertPositionToint :
        d : float *
        coordinateSystem : uint16 *
        scalarToBeAppliedToAllCoordinates : float -> int

Parameters

d
Type: SystemDouble
input position
coordinateSystem
Type: SystemUInt16
segy rev 1 trace header coordinate system
scalarToBeAppliedToAllCoordinates
Type: SystemDouble
segy rev 1 trace header scalarToBeAppliedToAllCoordinates

Return Value

Type: Int32
an integer value calculated using coordinateSystem and scalarToBeAppliedToAllCoordinates
See Also

Reference

SEGYUtilities Class


SEGYUtilities.convertToPosition Method

SEGYUtilitiesconvertToPosition Method
convert a SEGY trace header positional value to position

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double convertToPosition(
    int x,
    ushort coordinateSystem,
    double scalarToBeAppliedToAllCoordinates
)
Public Shared Function convertToPosition (
    x As Integer,
    coordinateSystem As UShort,
    scalarToBeAppliedToAllCoordinates As Double
) As Double
public:
static double convertToPosition(
    int x,
    unsigned short coordinateSystem,
    double scalarToBeAppliedToAllCoordinates
)
static member convertToPosition :
        x : int *
        coordinateSystem : uint16 *
        scalarToBeAppliedToAllCoordinates : float -> float

Parameters

x
Type: SystemInt32
segy rev 1 trace header position
coordinateSystem
Type: SystemUInt16
segy rev 1 trace header coordinate system
scalarToBeAppliedToAllCoordinates
Type: SystemDouble
segy rev 1 trace header scalarToBeAppliedToAllCoordinates

Return Value

Type: Double
a decimal position calculated using coordinateSystem and scalarToBeAppliedToAllCoordinates
See Also

Reference

SEGYUtilities Class


SEGYUtilities.decimalDegreesToDMS Method

SEGYUtilitiesdecimalDegreesToDMS Method
convert decimal degrees to degrees-minutes-seconds

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double decimalDegreesToDMS(
    double dg
)
Public Shared Function decimalDegreesToDMS (
    dg As Double
) As Double
public:
static double decimalDegreesToDMS(
    double dg
)
static member decimalDegreesToDMS :
        dg : float -> float

Parameters

dg
Type: SystemDouble
input decimal degrees

Return Value

Type: Double
DDDMMSS
See Also

Reference

SEGYUtilities Class


SEGYUtilities.degreesToSecondsOfArc Method

SEGYUtilitiesdegreesToSecondsOfArc Method
convert decimal degrees to seconds of arc

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double degreesToSecondsOfArc(
    double degrees
)
Public Shared Function degreesToSecondsOfArc (
    degrees As Double
) As Double
public:
static double degreesToSecondsOfArc(
    double degrees
)
static member degreesToSecondsOfArc :
        degrees : float -> float

Parameters

degrees
Type: SystemDouble
input decimal degrees

Return Value

Type: Double
seconds of arc
See Also

Reference

SEGYUtilities Class


SEGYUtilities.dmsToDecimalDegrees Method

SEGYUtilitiesdmsToDecimalDegrees Method
convert degrees-minutes-seconds to decimal degrees

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double dmsToDecimalDegrees(
    double DDDMMSS
)
Public Shared Function dmsToDecimalDegrees (
    DDDMMSS As Double
) As Double
public:
static double dmsToDecimalDegrees(
    double DDDMMSS
)
static member dmsToDecimalDegrees :
        DDDMMSS : float -> float

Parameters

DDDMMSS
Type: SystemDouble
input DDDMMSS

Return Value

Type: Double
a decimal position
See Also

Reference

SEGYUtilities Class


SEGYUtilities.Int2Bytes Method

SEGYUtilitiesInt2Bytes Method
convert a long int to bytes

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Int2Bytes(
    long integer,
    bool signed,
    byte[] byteArray,
    int start,
    int length,
    bool swap
)
Public Shared Sub Int2Bytes (
    integer As Long,
    signed As Boolean,
    byteArray As Byte(),
    start As Integer,
    length As Integer,
    swap As Boolean
)
public:
static void Int2Bytes(
    long long integer,
    bool signed,
    array<unsigned char>^ byteArray,
    int start,
    int length,
    bool swap
)
static member Int2Bytes :
        integer : int64 *
        signed : bool *
        byteArray : byte[] *
        start : int *
        length : int *
        swap : bool -> unit

Parameters

integer
Type: SystemInt64
input long int
signed
Type: SystemBoolean
is the value signed
byteArray
Type: SystemByte
output byte array
start
Type: SystemInt32
starting position in output array
length
Type: SystemInt32
length of output word
swap
Type: SystemBoolean
swap the output byte array

Return Value

Type:
byte array converted from long integer
See Also

Reference

SEGYUtilities Class


SEGYUtilities.secondsOfArctoDegrees Method

SEGYUtilitiessecondsOfArctoDegrees Method
convert seconds of arc to decimal degrees

Namespace: SEGYlib
Assembly: SEGYlib (in SEGYlib.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double secondsOfArctoDegrees(
    double secOfArc
)
Public Shared Function secondsOfArctoDegrees (
    secOfArc As Double
) As Double
public:
static double secondsOfArctoDegrees(
    double secOfArc
)
static member secondsOfArctoDegrees :
        secOfArc : float -> float

Parameters

secOfArc
Type: SystemDouble
input seconds of arc

Return Value

Type: Double
a decimal position calculated using seconds of arc
See Also

Reference

SEGYUtilities Class